Error: "This program has quit. You cannot connect to the pervasive database engine. [TS 2695]" (Pervasive database engine cannot communicate across network)
Description

Cause
The Pervasive/Actian/Zen database engine on your workstation or terminal server cannot communicate with the Pervasive/Actian database engine on the Sage 300 Construction and Real Estate file server.
Resolution
[BCB:3:Network warning:ECB]

 

Verify that your workstation or terminal server can communicate with your Sage 300 CRE file server. Contact your system administrator if you require assistance. Some examples of why the Pervasive/Actian/Zen database engine is unable to communicate across your network are as follows:

  • Name resolution is not functioning correctly from the server or the workstation:
    • From the workstation, ping the server by name and IP address.
    • From the server, ping the affected workstation by name and IP address. Verfiy server IP address using ipconfig.
    • If an entry in the Hosts file on the Workstation is using an incorrect IP Address for the Server. Either update the IP Address or remove the line.
    • Contact your network administrator for assistance correcting issues with network name resolution.
  • Use the Pervasive System Analyzer to test additional network connectivity. See How do I test Pervasive/Actian communication from my workstation to the server and vice versa? (using Pervasive System Analyzer)
  • Sage 300 CRE client software can connect to the Sage 300 CRE server using UNC paths or mapped drives.
    • If using mapped drives, your workstation or terminal server is incorrectly mapped using an IP address. For proper Pervasive/Actian communication, mapped drives must be configured using the server computer name, such as \\ServerName\Timberline Office\ and not something similar to \\192.168.0.x\Timberline Office\.
    • If using UNC paths, do not browse through Windows Explorer with an IP address such as \\192.168.0.x\Timberline Office\9.5\Accounting\Wininst\. Instead, use \\ServerName\Timberline Office\9.5\Accounting\Wininst\.

      Note: Do not use the fully qualified domain name when mapping drives. Example of NOT to use: servername.domain.local
  • A firewall is active and blocking Pervasive/Actian/Zen communication. Modify the firewall settings to allow Pervasive/Actian/Zen communication. Contact your system administrator for assistance. See What firewall port exceptions to set for Sage 300 CRE? 
  • A network cable is unplugged or the cable is faulty.
  • If using a wireless connection, disable the wireless connection and use a network cable instead. Wireless connections can intermittently disconnect and cause Pervasive/Actian/Zen problems and irreversible data corruption.
  • On the server:
    • Versions 24.1 and earlier: Open Pervasive Control Center (Start, Run: pcc) and click Configure Local Engine. Click Access and verify that the Accept Remote Request checkbox is selected.
    • Versions 24.2 and later: Open Zen Control Center (Start, Run: zencc) and click Configure Local Engine. Click Access and verify that the Accept Remote Request checkbox is selected.
  • Pervasive/Actian/Zen engine is not running on the server. See the link below.

    Note: When testing Pervasive/Actian/Zen communication with the server, perform ping command tests using both the IP address and computer name. Testing by IP address verifies network connectivity (i.e. firewall issues) and testing by computer name verifies name resolution (that DNS is working or DNS cache is correct).
  • The Application Data Directory entry in the registry (HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Timberline\General) on the Workstation is using an incorrect UNC for the server. Verify it matches the other workstations. Change from \\[Server Name].[Domain].COM\TIMBERLINE OFFICE\9.5\ to \\[Server Name]\TIMBERLINE OFFICE\9.5\ if needed.



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Steps to duplicate
Related Solutions

Error: "This program has quit. You cannot connect to the pervasive database engine. [TS 2695]" (drive mapped to server does not use servername)
Error: "This program has quit. You cannot connect to the Pervasive/Actian database engine. [TS 2695]" (Firewall blocking Pervasive ports)
Potential security vulnerability with Pervasive System Analyzer