Error: Cannot select invoices or "Invoice Already Being Paid" or "The invoice balance was exceeded" in Cash Receipts Entry or the balance for an invoice is showing zero or incorrect
Description


Cause
  • The invoice has a zero balance
  • The invoice is already selected for payment in another entry (perhaps in another deposit and/or in another batch) in Cash Receipts Entry
  • The invoice was previously selected for payment, but the entry was deleted or cleared, or there may have been a power outage or workstation crash in the meantime
  • The invoice has a short key and cannot be selected
  • Open invoice not showing in cash receipts
  • The invoice is missing from cash receipts
Resolution
[BCB:1:Backup warning:ECB]


Review the invoice to verify whether it has a balance

  1. Open Accounts Receivable, Main, Customer Maintenance
  2. Select or enter the Customer No. and click the Invoices tab
  3. Find the specific invoice and note any balances in the Invoice Balance column
  4. If the invoice has a balance, the Payments Today field in the open invoices file may be set incorrectly, indicating that the invoice is already being paid and proceed to the next step to reset the field.
  5. If the invoice does not have a balance, note the transactions posted to that invoice in the bottom grid.

Beginning with Sage 100 2021, r​​​​​​un the utility to correct the Paid Today field
For Sage 100 2020 and earlier, see Additional Information below

  1. All users must exit, Cash Receipts Entry and AP from AR Clearing Entry
  2. In Sage 100 Launcher click File and select Run
  3. Program, *utl
  4. Click Proceed
  5. Highlight "A/R Open Invoice Payments Today Utility" and click OK
  6. Click Proceed at message, "This utility will recalculate the Payments Today field in the Accounts Receivable Open Invoice file. Important: Before running this utility, everyone must exit Cash Receipts Entry and AP from AR Clearing Entry."

If the Paid Today utility does not work, following one of these steps

  • Reinitialize the cash receipts data entry files, see Article ID 20980,
    DocLink: How to reinitialize Accounts Receivable Cash Receipts Entry files
  • Manually edit the Payments Today field for the invoice record in question:
    • Select Library Master, Utilities, Data File Display and Maintenance
    • Browse to the ..\MAS90\MAS_xxx\ARxxx\AR_OpenInvoice.m4t file (where xxx = company code)
    • Click Key Scan button
    • Locate and select the invoice causing the error.
      • Note: The record key is made up of the division, customer number, and invoice number (for example 01ABF00000012IN)
    • Click Edit
    • For Field Number, select PaymentsToday$
    • For Change/Value, change to 0
    • Click OK, and closeout of Data File Display and Maintenance
    • Return to Cash Receipts Entry and attempt to pay the invoice again

If the invoice has a short key, editing through Data File Display and Maintenance (DFDM) may be necessary. Contact Sage 100 Support for assistance.

In Sage 100 2020 and earlier, run the ARWAR4 utility

  1. Have everyone exit out of the Accounts Receivable and Sales Order modules
  2. From the Sage 100 Desktop, click FileRun
    • Note: Your company Security settings may require Admin access to use or see the File or Run menus. If these options are missing, reach out to your Sage 100 Administrator for assistance
      • Note: The relevant permission is in Library MasterMain menu, Role Maintenance, Security Events tab, Library Master, "Enable File Run"
  3. For the Program field, enter ARWAR4 and click OK
    • Note: The Sage 100 User Logon must have role permision access set for one or more of the Roles assigned to the User Logon.
      • Note: The relevant permission is in Library MasterMain menu, Role Maintenance, Tasks tab, Accounts Receivable, "A/R Open Invoice Payments Today Utility"
  4. Click Yes at the prompt: "Warning: This utility will clear and recalculate the Payments Today field in the AR_OpenInvoice file. Do you want to proceed?"
    • Note: The utility will then go through all open invoice records in the AR_OpenInvoice table and change the Payments Today field to match the data in the AR_CashReceiptsHeader and AR_CashReceiptsDetail tables
  5. Click Yes at the prompt: "AR_OpenInvoice Payments Today amounts corrected."
  6. Return to Cash Receipts Entry and attempt to pay the invoice again
If you use third-party modifications for Sage 100, the third-party mod may have its own utility or task to perform these steps for you, such as one called Clear Paid Today in its Utilities folder.


DocLink: Error: "A task ID or program name has not been associated with this menu item."
DocLink: How to use the Data File Display and Maintenance (DFDM) utility
DocLink: How to erase or manually recreate data files using the Reinitialize Data Files utility
DocLink: How to use Cash Receipts Entry to apply credit memos and prepayments to invoices

[BCB:155:Chat 100 US:ECB]

Defect ID
Steps to duplicate
Related Articles