Slow Performance when printing Crystal forms or reports since upgrade from a version prior to Sage 100 2013
Description
Cause
  • Conflict of DLL’s on the workstations that could be a result of multiple version of the workstation being installed
  • Multiple versions of Crystal Reports installed
  • Third Party programs that use different version of Crystal Reports
  • Anti-Virus Configurations
  • Bad custom Form or Report
  • Changes with the new SAP Crystal Reports software
  • Bold Sans Serif font on forms
Resolution
[BCB:4:Operating system warning:ECB]

Note: One or more causes of this issue were resolved in Product Update 5 for Sage 100 2013. However, if the issue is still occurring, consider the following:

  • For the "Printer Not Activated. Error Code -30" message when trying to print:
    • Copy the following DLL files from "C:\Program Files (x86)\Business Objects\Common\3.5\Bin" to "C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86"

      • U25STORE.DLL
      • U2LMAS90.DLL
      • U25TOTAL.DLL
    • Give full control to folder "C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86"
    • Note: If the computer is a 32-bit machine, substitute "Program Files" for "Program Files (x86)"
  • For possible speed performance improvements, set the antivirus exclusions:
    • Note: For more information, see the Related Resources section on how to exclude Sage 100 from antivirus scans
  • For Sage 100 Advanced editions
    • Consider using the Client/Server ODBC Driver to handle Crystal Report print processes. For more information, see the Related Resources section on how to install and configure the Client/Server ODBC driver
  • If only one or a few forms or reports are slow, but others are not slow:
    • Perhaps a lot of data being processed for that form or report (especially if it is a report based on history files)
    • The form or report has been customized - such as with formulas or additional tables. A Crystal Report pulling data from more than one table will be slower. Sage 100 Customer Support cannot assist with troubleshooting customized or modified Crystal Report forms or reports.
DocLink: DUPLICATE of 51211: How to install and configure the Client/Server ODBC driver for Sage 100 Advanced version 2013 and higher
DocLink: How to find or access additional Crystal Reports resources and help for Sage 100
DocLink: How to exclude Sage 100 from anti-virus (antivirus) Real-time scans
DocLink: How to install and configure the Client/Server (C/S) ODBC Print driver for Sage 100 Advanced version 2013 and higher
Defect ID
Steps to duplicate
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