Error: "Unable to log on to the specified email account." in MyAssistant
Description

Cause

This can be caused by a variety of reasons:

  • Incorrect Outgoing Mail Server
  • Outgoing Mail Server is using AD FS (redirects for logon)
  • Incorrect Username
  • Incorrect Password
  • Incorrect TCP/IP port
  • Incorrect settings for SSL connection
  • Firewall is blocking communication - Internal or external
  • Anti-virus or spam software is blocking communication
Resolution
[BCB:3:Network warning:ECB]


MyAssistant is independent of any mailing program. MyAssistant uses SMTP to send information to the mail server you define. By default the port used is 25. You may specify a different port if required in the Outgoing Mail Server field. For example you might use smtp.gmail.com:587 to specify port 587.

Troubleshooting:

  • Can you ping the Outgoing Mail Server?
  • Can you telnet to the Outgoing Mail Server using the specified TCP/IP port?
  • Review the Windows Application event viewer to verify that you are get denial/refusal messages.
  • Add exceptions to your anti-virus or Internet filtering software for MyAssistant.exe, ISDAdminService.exe and MyAssistantConfigurationManager.exe.
    Note: This only needs to be done on the server.


For Microsoft 365 users:

AD FS: MyAssistant is not compatible with AD FS as the logon is being redirected to another service rather than logging directly into the mail server.

Steps to duplicate
Related Solutions

How do I set up MyAssistant email settings? What do the fields mean?