Error: "Printer not activated. Error Code -30" occurs when printing to TS PDF Generator
Description
Cause

Common causes

  • You printed to the TS PDF Generator instead of printing to a file
  • Inadequate permissions
  • TS PDF Generator has a corrupt installation, didn't get created during the install process, or was removed
Resolution

Contact your IT provider if you need assistance with the following steps.

Verify if Print to File works with other printers

Example: Test printing to the Microsoft XPS Document Writer

  1. In Sage, follow the steps until you're at the Print Selection dialogue box.
  2. Select Printer Setup, and then in the Printer field, select a printer driver other than TS PDF Generator.
  3. Check the box for Print to File, then Select File.
  4. Change the Save as type to the desired format.
  5. Follow the rest of the steps to create the file.

If these steps work, the issue is related to the TS PDF Generator print driver. Follow the steps to remove and reinstall the TS PDF Generator.

Set Sage 300 CRE Desktop app to Run as Administrator

  1. Browse to C:\Program Files (x86)\Timberline Office\Shared and locate the Desktop app.
     NOTE: You can also type Desktop in the Windows search field to locate the app. 
  2. When you've located the app, right-click it and select Properties.
  3. Select the Compatibility tab.
  4. Click Change settings for all users button at the bottom.
  5. Under settings, check the option for Run this program as an administrator.
  6. Click Apply and then OK.

Set a default printer

You must have the default printer set to a physical printer or another printer device that isn't TS PDF Generator.

  1. Launch Sage Desktop.
  2. Under Common Tasks, File, Printer Setup.
  3. In the Printer Selection window, select your default printer from the drop-down.

Uninstall and reinstall PDF Driver

See steps to remove and reinstall the TS PDF Generator.

Install locally on Remote Desktop Workstations

Remote Desktop Workstations need to have the PDF Generator locally installed. If it's not installed, follow these steps to install it.

  1. Copy the Printer driver from the network location: \ServerName\Timberline Office\9.5\Accounting\Wininst\Prerequisites\PDF Converter\RunAmyunillnst.exe.
  2. Paste on to the local Windows desktop and run to install.

Some Remote Desktop users have Printer Redirection setup. You can disable this in the Remote Desktop app using these instructions.

  1. Go to Administrative Tools.
  2. Open the Remote Desktop Services folder.
  3. Select Disable device redirection for the following client device types.
  4. Place a checkmark at Printers.
  5. Click OK.

 

 

[BCB:156:Chat 300 CRE US:ECB]



 

Steps to duplicate
Related Solutions

Error: "This program has quit. The TS PDF Generator printer is not installed. [TS 4220]"