Error: "This program has quit. The TS PDF Generator printer is not installed. [TS 4220]"
Description
Cause

The TS PDF Generator printer didn't get installed or the installation has become corrupt.

Resolution

CAUTION:

This solution needs advanced Operating System knowledge. Consult your system administrator for help. Sage isn't liable for issues caused by improper changes to the Windows Registry. Always back up your data before applying advanced solutions.

Manually install/reinstall the TS PDF Generator

  1. Go to Start, Settings, Devices, and Printers and Scanners.
  2. Delete the Amyuni Document Printer and the TS PDF Generator if these printers appear on your list. 
  3. Browse to the \\[ServerName]\ProgramData\Sage\TIMBERLINE OFFICE\9.5\ACCOUNTING\WinInst\Prerequisites\PDF Converter folder.
  4. Double-click the install.exe or RunAmyUniInst.exe file and install the TS PDF Generator.
    • Receiving the message "Copying xmlite.dll file Error Code 2" doesn’t indicate a failed installation.
    • The Amyuni installer runs silently.
  5. Click OK.
  6. Select Start, Printers and Faxes.
  7. Rename the Amyuni Document Printer to TS PDF Generator, if necessary.
  8. Right-click the TS PDF Generator and select Printer Properties.
  9. On the Advanced tab, verify the following settings:
    • Always Available
    • Priority: 1
    • Driver: Amyuni Document Converter 400 or Amyuni Document Converter 450
    • Spool print documents so program finishes printing faster
    • Start printing after last page is spooled
    • Uncheck the box "Enable Advanced Printing Features"
  10. On the Security tab:
    • Set the user or the Everyone group to allow Print, Manage this printer, and Manager documents
    • On the Ports tab, make sure the printer is using the NUL: port
  11. Print your document to Excel from Sage 300 CRE.
Steps to duplicate
Related Solutions

Error: "Printer not activated error code -41" or "...error code -30" (Insufficient Permissions)

Error: "Printer not activated. Error Code -30"