Error: "Pervasive Status Code 171"
Description
Cause

Database engine

The Pervasive/Actian/Zen SQL database engine runs as a service. It uses the local System account by default. The local System account usually doesn’t have access to data on another server.

Use Cache Engine

You checked the Use Cache Engine option in Pervasive Control Center/Zen Control Center and the Pervasive/Actian/Zen service is using the Local System account.

Resolution

Modify the Pervasive/Actian/Zen service to log on as an Admin user

Contact your system administrator if you require assistance changing these settings on your workstation.

Domain

  1. On your keyboard, press Windows key + R.
  2. Type: Services.msc.
  3. Click OK.
  4. Right-click the Pervasive/Actian/Zen service.
    • Example: Actian PSQL v12 Client
    • Example: Pervasive PSQL v11 Workgroup
  5. Select Properties.
  6. Click the Log On tab.
  7. Select This account.
  8. Enter the DOMAIN\ADMINISTRATOR account and password.
  9. Right-click Pervasive/Actian/Zen service and select Restart.

Workgroup

  1. Create a local admin account on the workstation. Make it identical to the local Admin account on the server (same user name and password).
  2. Add the new local admin account to the Actian service on the client.
Steps to duplicate
Related Solutions

Error: "This program has quit. I/O Error. Pervasive status code 171" (workstation not on a domain)

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