How do I create a test data folder if Service Management is used?
Description

In Service Management 9.4.0 and later, a GUID from the ts.ctl file is used to set up the DSNs for Service Management reports. If live data was copied to a different data folder for testing or to set up a new data folder, the ts.ctl files share the same GUID and the report DSNs are not set up correctly in the new folder.

Cause

The test company folder must have a unique ts.ctl, master.qym, and tswin.ini files.

Resolution
[BCB:3:Network warning:ECB]
 
  1. Use File, New Company Folder to set up a new folder for this data.
  2. Use File Tools to copy the data from the test data folder into the new folder. Do not overwrite the new ts.ctl, master.qym, and tswin.ini files. For more information on how to use File Tools to copy files, select the link below.
  3. Open the new company folder and verify that the settings are correct. For example, verify formatting, posting settings, batch names, batch totals, accounting methods, file locations, and named files.


Recreate and verify the DSNs:

  1. At the server, open Service Management.
  2. From the Reports menu, select Work Orders,  Work Orders in Progress for all unique Service Management data folders.
  3. Open the ODBC Administrator.
  4. Select the System DSN tab and verify there is a unique DSN for each data folder.
DocLink: How do I move or copy files using File Tools?
DocLink: How do I create a new data folder?
Defect ID
520285
Steps to duplicate
Related Articles