Error: "Failed to retrieve data from the database" (ODBC DSN not configured properly)
Description
Cause
The ODBC Data source configuration does not match the crystal report.
Resolution

Verify that your Timberline Data Source DSN is configured properly:

  1. From the Windows task bar, click Start and select All Programs, ODBC, 32bit ODBC Administrator.
  2. Select the Timberline Data Source.
  3. Select Configure.
  4. Click Select Folder and then select the folder that contains the data you want to use.
  5. Click OK.
  6. Click Options.
  7. Specify the Table and Field Naming as Standard Descriptions.
  8. Check the Use maximum table segment size check box.
  9. Clear the Shorten field and table names check box.
  10. Click OK twice.

If the message persists see How do I use the Set Location and Verify Database features for Crystal reports or subreports that use an ODBC DSN?

Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from database" / "Failed to retrieve data set" / "Report operation failed" (Role does not have ODBC Read access)
How do I use an ODBC data source name (DSN) for my Sage 300 Construction and Real Estate data in a Crystal report?
Error: "Failed to retrieve data from the Database" (Troubleshooting)