Error: "You Cannot Use Sage 50 right now because the serial number(s) you have..." after it closed abnormally
Description
Cause
  • Program closed abnormally
  • Open files stuck in memory
Resolution

Section 1: Restart Pervasive/Actian

  1. Refer to How to stop or start the Pervasive/Actian service.
  2. Verify when open Sage and company you no longer receive the error.

Section 2: Abnormal close or open files stuck in memory

  1. Close Sage on all workstations and the server
  2. At the server, select Start, and then select Control Panel
  3. Select System and Security, and then select Administrative Tools

Note: Depending on your current view, you may not see System and Security. You will see Administrative Tools instead.

  1. Double-click Computer Management
  2. Double-click System Tools, Shared Folders, and then double-click Open Files
  3. Highlight any open Sage related file and close them
  4. Open company in Sage, verify no longer receive error

Note: The quicker way to get to the open files, press Windows+R keys, type fsmgmt.msc, and then click OK. Select Open Files, you may have to make the screen bigger by selecting Maximize button. You can then proceed to Step 6.

Section 3: Number of Pervasive licenses

  1. Run SageReg.exe in program path, follow How to find data path and program path.
  2. Select Key Status tab.
  3. On the Permanent line, check number of User Count.
  4. Activate in SageReg.exe to update if not enough.
[BCB:161:Chat 50 US:ECB]
Steps to duplicate
Related Solutions