Error: "Failed to retrieve data from the database Details: [Database Vendor Code: 31740]"
Description
Cause

The DSN used on the report is missing or corrupt.

Resolution

Recreate the data source

Remove the data source and add it back.

  1. From the Windows Start menu, select All Programs, ODBC.
  2. Select the correct administrator for your version.
    • Versions 25.2 and earlier: 32-bit ODBC Administrator
    • Versions 26.1 and later: 64-bit ODBC Administrator
  3. Select Timberline Data Source and click Remove.
  4. Click Add.
  5. Select Timberline Data and click Finish.
  6. Enter Timberline Data Source as the Data Source Name.
  7. Select Accounting Data Folder from the Database Type dropdown.
  8. Click Select Folder and select the applicable company and click OK. If you have multiple companies, select any active company.
  9. Click Options.
  10. Select Standard Descriptions from the Table and Field Naming dropdown.
  11. Select Use maximum table segment size.
  12. Clear Shorten field and table names.
  13. Click OK and close.

Alternate solutions

  • If a Billing invoice format has the error, creating the TS Billing Field Names DSN can resolve.
  • This can occur due to subreports in the BLNP and BLCP. The error only occurs when opened from the Billing application. Instead, launch Contract-Based Invoices or Invoice Formats from the Sage Desktop.

Steps to duplicate
Related Solutions

How do I set up an ODBC User DSN for Accounting and Management data?

Error: "Failed to retrieve data from database" when previewing Billing invoice (Error in BLNP.crs or BLCP.crs)

Error: "Failed to retrieve data from the Database" (Troubleshooting)