Error: "Failed to retrieve data from the database Details: [Database Vendor Code: 31740]" (DSN is corrupt)
Description
Cause
The DSN used on the report is missing or corrupt.
Resolution

Remove the data source and add it back. If your report is using the Timberline Data Source:

  1. From the Windows Start menu, select All Programs, ODBC, 32 bit ODBC Administrator.
  2. Select Timberline Data Source and click Remove.
  3. Click Add.
  4. Select Timberline Data and click Finish.
  5. Enter Timberline Data Source as the Data Source Name.
  6. Select Accounting Data Folder from the Database Type dropdown.
  7. Click Select Folder and select the applicable company and click OK.
    Note: If you have multiple companies, select any active company.
  8. Click Options:
    • Select Standard Descriptions from the Table and Field Naming drop down.
    • Select Use maximum table segment size.
    • Clear Shorten field and table names.
  9. Click OK and close.

Note

  • If this is a Billing Invoice format that has the error, creating the TS Billing Field Names DSN may also resolve the issue.  See article 19968 " below for steps on how to set up this DSN.
  • This may be related to subreports in the BLNP and BLCP and error only occurs when opened from the Billing application.  Instead, launch Contract based Invoices or Invoice Formats from the Sage Desktop.

DocLink: How do I set up an ODBC User DSN for Accounting and Management data?
DocLink: How do I set up an ODBC TS Billing Field Names DSN to modify or create Billing invoice formats?
DocLink: Error: "Failed to retrieve data from database" when previewing Billing invoice (Error in BLNP.crs or BLCP.crs)
DocLink: Error: "Failed to retrieve data from the Database" (Troubleshooting)
Defect ID
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