Error: "Failed to retrieve data from the database. Details: [Database Vendor Code: 31837]"
Description
Cause

The specific Sage 300 CRE user doesn't have access to ODBC in Security Administration.

Resolution
  1. Log into Sage Desktop as an Application Administrator.
  2. From the Options menu, select Security Administration.
  3. Click Role Setup and select the applicable role.
  4. To confirm the roles assigned, click User Setup, select the user, and click the Roles tab.
  5. On the Tasks tab, expand Tasks, then expand ODBC.
  6. Select the check applicable checkboxes for Read Access and Write Access.
  7. Click Save Changes.
  8. The changes will take effect when the user next logs in to Sage 300 CRE.

 

 

[BCB:156:Chat 300 CRE US:ECB]
Steps to duplicate
Related Solutions

How do I give users access to setup, tasks, tools, reports, or inquiries?

Error: "Failed to retrieve data from database" (non-Application Administrators unable to print Billing invoice formats)

Error: "[file name] file is incompatible. The current security settings prohibit this file from being upgraded automatically"

Error: "Failed to retrieve data from the Database" (Troubleshooting)