Error: "Failed to retrieve data from the database"
Description
Cause

Incompatible Crystal Runtime Components installed.

Resolution
[BCB:5:Third-party support:ECB]

 

Remove and reinstall the SAP Crystal Reports runtime engine for .NET Framework for the correct version of Sage 300 CRE Accounting on the affected machine.

  • Sage 300 CRE Accounting version 17.1 installs v13.0.19.2312 of the SAP Crystal Runtime
  • Sage 300 CRE Accounting version 18.1 installs v13.0.19 of the SAP Crystal Runtime

Run the SAP Crystal Runtime installer for versions 17.1 and higher. Locate it on the Sage 300 CRE server:

  • \\[ServerName]\TIMBERLINE OFFICE\9.5\Accounting\WinInst\Prerequisites\Crystal Runtime Engine (x86)\CRRuntime_32bit_13_0_19.msi

Once you've resolved this problem, confirm you can print Crystal-based reports in Sage 300 CRE. If you're still unable to run standard Sage Fixed Assets reports, refer to Crystal Runtime Version Conflict.

 

 

[BCB:156:Chat 300 CRE US:ECB]
Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from the Database" (Troubleshooting)
What are the Crystal Runtime compatible versions of the recent releases of Sage 300 CRE, Sage Estimating, and Sage Fixed Assets?