Error: "Failed to retrieve data from the database"
Description
Cause

Incompatible Crystal Runtime Components installed.

Resolution

CAUTION:

Sage support can't assist with third-party products, hardware, report customizations, or state and federal tax questions. Refer to our Scope of Support for more info. Contact your Sage business partner, network administrator, or accountant for assistance.

  1. Remove and reinstall the SAP Crystal Reports runtime engine for .NET Framework for Sage 300 CRE.
    • Versions 17.1 - 18.1 installs SAP Crystal Reports runtime engine for .NET Framework (32-bit) version 13.0.19.2312
    • Versions 18.2 - 25.2 installs SAP Crystal Reports runtime engine for .NET Framework (32-bit) version 13.0.22.2668
    • Versions 26.1 and later installs SAP Crystal Reports runtime engine for .NET Framework (64-bit) version 13.0.38.5404
  2. Run the SAP Crystal Runtime installer. Locate it on the Sage 300 CRE server.
    • Versions 17.1 - 18.1 installer file: \\[ServerName]\TIMBERLINE OFFICE\9.5\Accounting\WinInst\Prerequisites\Crystal Runtime Engine (x86)\CRRuntime_32bit_13_0_19.msi
    • Versions 18.2 - 25.2 installer file: \\[ServerName]\TIMBERLINE OFFICE\9.5\Accounting\WinInst\Prerequisites\Crystal Runtime Engine (x86)\CRRuntime_32bit_13_0_22.msi
    • Versions 26.1 and later installer file: \\[ServerName]\TIMBERLINE OFFICE\9.5\Accounting\WinInst\Prerequisites\Crystal Runtime Engine (x86)\CR13SP38MSI64_0-80007712.msi

Once you've resolved this problem, confirm you can print Crystal-based reports in Sage 300 CRE.

If you're still unable to run standard Sage Fixed Assets reports, see information about Crystal Runtime version conflicts.

 

[BCB:156:Chat 300 CRE US:ECB]
Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from the Database" (Troubleshooting)

What are the Crystal Runtime compatible versions of the recent releases of Sage 300 CRE, Sage Estimating, and Sage Fixed Assets?