Crystal Runtime Version Conflict
Description
Cause

Errors caused by Crystal Runtime version conflict errors include: 

  • Unable to cast COM object of Type... 
  • Load report failed
  • The document has not been opened

A Crystal conflict refers to different versions of the SAP ® Crystal Reports Runtime elements beginning installed on the same workstation. These runtime elements can be integrated into the installation of a program which is what the Sage Fixed Assets does or it can be a separate element on the installed programs list in Programs and Features.

Any application that installs SAP ® Crystal Reports runtimes SP20 (13.0.20) or earlier on top of Sage Fixed Assets version 2018.1 and higher will cause errors on reports.

Resolution
Notes:


  • Sage Fixed Assets updated to 2019.1.2 and higher will prompt with a Crystal Runtime Version Conflict message which will attempt to fix the problem automatically. If a prompt appears, select Close when prompted and re-launch Sage Fixed Assets – Depreciation
  • Sage X3: There is no current workaround other than installing Sage Fixed Assets to another machine
  • Sage 100: Update to the latest version of all Sage products when installed together
  • Sage 300 CRE: A repair install may allow Sage Fixed Assets to reproduce reports, but this will break reports in Sage 300 CRE. Install Sage Fixed Assets on another machine. See Crystal conflict Sage Fixed Assets 2023.1 and Sage 300 CRE
  • Sage 500: See Crystal conflict Sage Fixed Assets 2023.1 and Sage 500
  • This solution is the manual process and assumes Sage Fixed Assets is unable to generate reports or the Crystal Runtime Version Conflict message continues to appear on opening the program and there is only Sage Fixed Assets and another Sage product on the system using a SAP ® Crystal Reports runtime version.
  • See Known Third Party Crystal Conflict List for more information if there are no other Sage Products on the system


In Windows Explorer:

For Sage Fixed Assets Lite Depreciation, Sage Fixed Assets Lite Depreciation for Sage 50, and Sage 50 Fixed Assets:

  1. Browse to C:\Program Files (x86)\Common Files\Sage SBD\SBDDesktop\v14.
  2. Copy/Paste SBDDesktop.exe.config to create a backup copy.
  3. Edit the SBDDesktop.exe.config.
  4. Delete all content between the first and the last .
  5. Save and close the file.

For Sage Fixed Assets Single User, Network and Premier modify the following files:

  1. SBDDesktop.exe.config:
    1. Browse to C:\Program Files (x86)\Common Files\Sage SBD\SBDDesktop\v14.
    2. Copy/Paste SBDDesktop.exe.config to create a backup copy.
    3. Edit the SBDDesktop.exe.config.
    4. Delete all content between the first and the last .
    5. Save and close the file.
  2. T2S8RptContainer.exe.config:
    1. Browse to C:\Program Files (x86)\Sage Fixed Assets\Common Files.
    2. Copy/Paste T2S8RptContainer.exe.config to create a backup copy.
    3. Edit the T2S8RptContainer.exe.config.
    4. Delete all content between the first and the last .
    5. Save and close the file.
  3. cdnTax.exe.config:
    1. Browse to C:\Program Files (x86)\Sage Fixed Assets\Depreciation, Depreciation, Network or Premier Depreciation.
    2. Copy/Paste cdnTax.exe.config to create a backup copy.
    3. Edit the cdnTax.exe.config.
    4. Delete all content between the first and the last .
    5. Save and close the file.
  4. fca.exe.config:
    1. Browse to C:\Program Files (x86)\Sage Fixed Assets\FCA.
    2. Copy/Paste fca.exe.config to create a backup copy.
    3. Edit the fca.exe.config.
    4. Delete all content between the first and the last .
    5. Save and close the file.
  5. FasCIPNT.exe.config:
    1. Browse to C:\Program Files (x86)\Sage Fixed Assets\Planning, Planning Network or Premier Planning.
    2. Copy/Paste FasCIPNT.exe.config to create backup copy.
    3. Edit the FasCIPNT.exe.config.
    4. Delete all content between the first and the last .
    5. Save and close the file

If the error still occurs, repair the installation of the Depreciation Client. After opening, choose Cancel when the version conflict error pops up.


To verify the current Crystal Runtime version is on the computer: In the Registry, go to:

  • HKEY_Local_Machine\Software\Wow6432Node\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Crystal Reports and look at the value in the CRRuntimeMSMVersion. This will be the version of the last Crystal runtime installed onto the computer



[BCB:165:Chat Fixed Assets US:ECB]




Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from the database"