Description
Error: "Database Service Manager has stopped working"
Error: 22665
Error: 22665
Cause
- Security software preventing installation/configuration
- Other programs running preventing installation/configuration
- User Account Control (UAC) enabled
- Previous installation of Actian Zen damaged
- Damaged installation files
- Security settings on installation folder
- One of the workstations has the program open
- Insufficient Windows user rights (non-Admin)
- VIPRE antivirus and Firewall can both cause this message to appear and once disabled, the installation should complete
- Have the PSQL Server engine 64 bit installed
Resolution
CAUTION: This solution requires advanced knowledge of your computer's operating system. Contact your system administrator for assistance. Modifying your Windows Registry incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows Registry. Always create a backup of your data before proceeding with advanced solutions.
Section 1: Try Restarting the computer first before trying the other steps
Section 2: Security software, security settings, or other programs preventing installation
- Before starting the installation, disable any antivirus software on the computer
- It may be necessary to disable User Account Control, refer to How to disable User Account Control (UAC)
- It may be necessary to install in Selective Startup. Refer to How to boot into selective startup?
- Right-click setup.exe, and then select Run as administrator
- Verify the security settings on the install folder (default location: C:\Sage\Sage50_[Release]_[Version]) are set so System and Everyone have Full control.
Section 3: Verify the correct installer is used
- Make sure you are using setup.exe located in the Install directory for the version of Sage you are trying to install
- For example, if installing Version 2022, the directory would be Sage50_2022_[Version]
- If using another setup file located somewhere else, exit the install wizard, browse to the correct directory, and double-click setup.exe.
Section 4: Uninstall and reinstall Actian Zen
- Refer to How to completely remove and reinstall Actian Zen
- Attempt the installation again.
Section 5: Windows user rights
- Verify the current user is a Windows local administrator; if not, either give the user local admin rights, or log in as a local admin.
- If using a domain network, verify the current user is both a local admin and a domain admin; if not, either give the user local and domain admin rights, or log in as an administrator that has both.
Section 6: Verify if there is an incompatible version of Actian software
- From the Control Panel in Windows, open Programs and Features
- Uninstall other versions of Actian if found, it may be listed as Actian PSQL v12 Server Engine SP1
- Verify you can install the Sage program.
Section 7: Run the standard installation from the server
- Browse to \\ \PeachtreeInstaller20xx (for example: PeachtreeInstaller2024)
- Right-click Setup.exe and select Run as administrator.