Summary
Reports freeze, calculating payroll gets stuck, or month-end close doesn't complete when a blank employee record exists in Sage BusinessWorks.
Description
The following tasks freeze or won't complete
- Month-end close
- Rebuild data files
- Automatic Payroll Calculation
- Direct Deposit Preview Report
- Payroll reports
Cause
A blank employee record exists.
Resolution
Watch the video
Watch this short video on how to fix an issue due to a blank employee.
Follow the steps to delete or rename the employee record
- On the PR menu, go to Employees, and click Maintain Employees.
- Look at the first record that displays. If no employee ID displays, you have a blank record.
- Click the Rename button and give the blank record an ID such as ZZBLANK.
- Click the Delete button, if it’s available.
- To update your employee count, rebuild your payroll data files.
- If the Delete button is unavailable, continue processing your payroll.
- Contact Sage Customer Support to schedule a data analysis to remove the record
NOTE: A Blank ID will cause a task to remain open. If that occurs, disconnect the stuck users or tasks.
If you can’t click cancel to cancel out of a task
- Press Ctrl-Alt-Del on the keyboard to access the Windows Task Manager.
- Click the Processes tab.
- Select the checkbox to show processes for all users.
- Scroll through the list to locate processes with Taskxxxx.exe. For example, the word Task followed by four numbers. (Task 5007.exe or any Taskxxxx.exe).
- Highlight the task, and click the End Process button.
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