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How to set up the PDF attachment folder Network or Premier Depreciation

Created on  | Last modified on 

Summary

Steps to set up the attachments folder path in the Database Utility – Network/Premier Depreciation &Tracking.

Description


Cause

If the Attachments Path is incorrectly set up or the users don’t have modify rights to the location, it will cause errors when attempting to view, attach, or modify images.

Resolution

On the Depreciation Network or Premier Depreciation server:


  1. Launch the Database Utility – Network/Premier Depreciation & Tracking:
    Go to, Start, Programs, Sage Fixed Assets, Tools, Database Utility – Network/Premier Depreciation & Tracking.
  2. Setup PDF attachment folder location:
    1. In the Attachments Folder section, click Browse.
    2. In Folder, clear any existing text.
    3. Type in a UNC path to the Shared folder you want to use for PDF file attachments.
      Note: During the server installation, the program creates a default location at \\<server name>\SFAServ\COMMON\Attachments. If you use a different folder, share the folder to the SFA User accounts with Read/Write access.
  3. Click OK to close the Browse for folder dialog. The selected folder will appear in the Attachments Folder field in the UNC format.
  4. Click Exit to close the Database Utility.

Note: If you set up the Attachment folder correctly on the server and you still have the message: "The system has detected that you must specify the path to the Attachments folder before you can access the program", access the Database Utility found under the Sage Fixed Assets Tools on the server, compare the NWBESTSYS for Network or MSBESTSYS for Premier registry key of the workstation and the server to make sure the workstation has the same enginename.


When a PDF file is attached to the program, the program copies it to the Attachments Path location and renames it in the following format:

  • ServiceID - is the index field used in the System Database to identify the Database file the PDF is attached to
  • CompanyID - is the index field used in the Asset Database to identify the Company within the database
  • ImageID - is the index field used in the Asset Database to identify the specific Image
  • Image Name - is the name entered by the user when you added the image to the Image Manager

If the Database Utility shows a valid attachments path and the User rights are correct, but the error still occurs: The client is connecting to a different Bestsys database.

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