Run the IM_CommitCheckClear_utl and IM_ClearCommitDataEntry_utl utilities

Summary

Steps to run the IM_CommitCheckClear_utl and IM_ClearCommitDataEntry_utl utilities in Sage 100.

Cause

  • Values can get stuck in CostCalcQtyCommitted or CostCalcCostCommitted fields during Transaction Register updates or previews.
  • They can cause Quantity On Hand and costing issues.
  • Run these utilities to remove stranded values and create a CSV file of removed committed records.
  • You can only use these utilities when there are no inventory-related transactions to update. 

    This includes, but isn’t limited to:

    • Sales Order Invoices
    • Purchase Order Receipt/Return of Goods
    • Return Merchandise Authorization Receipts
    • Bill of Materials Production Entry
    • Inventory Management Transactions/Physical Count

Resolution

To run the IM_CommitCheckClear utility

  1. Copy the IM_CommitCheckClear_utl and IM_ClearCommitDataEntry_UTL program files from the ..\MAS90\Utility folder to the ..\MAS90\IM program file.
  2. Open File, Run and type syzcon Click OK.
  3. At the command prompt, type: run "IM_CommitCheckClear_utl" and OK.
  4. The program will prompt with the following warning: "Warning: This utility should not be run while registers have not been updated. Do you want to proceed?".
  5. Click Yes to Continue, Click No to quit the program.
  6. If any issues are found, the message "IM Commit Check Clear Utility Check completed. Do you want to clear them?" will display.
  7. Click Yes and the message "The IM Commit Check Clear Utility for Company xxx has been successfully completed. Results can be viewed in.. HOME/TEXTOUT/IMCommitCheckClear001.csv".
  8. If no issues are found, the message "The IM Commit Check Clear Utility for Company xxx found no issues to review" will display.
  9. You can then review the report in Excel. The reports are saved by adding a sequence number to the end so comparisons can be made to isolate the cause of the issues.
  10. The program will also add an entry to the Activity Log.

To run the IM_ClearCommitDataEntry utility:

  1. Open File, Run and type syzcon Click OK
  2. At the command prompt, type: run "IM_ClearCommitDataEntry_utl" and OK.
  3. The program will prompt with the following warning: "Warning: This utility should not be run while registers have not been updated. Do you want to proceed?"
  4. Click Yes to Continue, Click No to quit the program.
  5. If any issues are found, the message "IM Commit Check Clear Utility Check completed. Do you want to clear them?" will display.
  6. Click Yes and the message "The IM Clear Commit Data Entry Utility for Company xxx has been successfully completed. Results can be viewed in.. HOME/TEXTOUT/IMCommitCheckClear001.csv"
  7. If no issues are found, the message "The IM Clear Commit Data Entry Utility for Company xxx found no issues to review" will display.
  8. You can then review the report in Excel. The reports are saved by adding a sequence number to the end so comparisons can be made to isolate the cause of the issues.
  9. The program will also add an entry to the Activity Log.

 

 

 

Related Solutions

Inventory Item Costs are incorrect as result of stranded records in CostCalc fields
How to Correct Out-of Balance Inventory Items for Average Cost items 
How to confirm inventory quantity is in balance for an item

Solution Properties

Solution ID
222924550020946
Last Modified Date
Tue Dec 02 18:21:18 UTC 2025
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