Skip to content

Error: Update failed in file ***.dat. Btrieve encountered a record level conflict 80.

Created on  | Last modified on 

Summary

The error can reference multiple file names, and usually looks like this: "Update failed on file OPTIONS.DAT. Btrieve encountered a Record Level Conflict 80"

Description

Cause

The record level conflict error is a Btrieve error indicating the file is locked or in use.

There may be more than one person attempting to access the record simultaneously. Or, a single person may be performing multiple tasks that use the same files.

Resolution

To try to unlock the file, complete the following:

  1. Close and restart the application. Try to recreate the error. If you cannot recreate the error, the file is unlocked and you do not need to continue further. If you can recreate the error, go to step 2.
  2. Restart the workstation. Try to recreate the error. If you cannot recreate the error, the file is unlocked and you do not need to continue further. If you can recreate the error, go to step 3.
  3. Instruct all operators to exit the network. Restart the server. Try to recreate the error. If you cannot recreate the error, the file is unlocked and you do not need to continue further. If you can recreate the error, go to step 4.
  4. Review the task you attempted to complete and the record that is not available. Are you trying to enter a duplicate customer number or vendor, or a part that is already entered? Use the combination of the record and the task to assist in determining the problem. If the error continues to appear, contact Sage Timberline Office Customer Support.
DocLink: Error: "File in Use" or "Record in use"

Need more help?

Chat now