Summary
Description
Accounts Payable Enter Pending Invoices task aborts when a specific pending invoice session is selected: "This program has quit. Invalid form field number TS 5618". This only occurs on a specific pending invoice session. New sessions open normally.
Accounts Payable Enter Pending Invoices tasks aborts when the task attempts to open.
Cause
This may be caused by one of the following:
- The Pending Invoices task window was resized too small and is saved to that pending invoice session.
- There is a corrupt pending invoice in the new.api file.
Resolution
Confirm the abort occurs for other users in the same company data folder before proceeding with the solution below.
Note: If the abort occurs when tabbing or entering to the distribution grid, it is neither of the above causes and is instead article Error: "Invalid form field number [TS 5618]" (in AP tasks)
If you have the Pending System setting set to Multiple Users:
- In Accounts Payable from the Tasks menu, select Enter Pending Invoices.
- In the Session field, enter a new session ID. For example: test
- In the box Select any or all additional sessions from the list below, select the problem session ID.
- Click OK. The pending invoice window should open normally to full size.
- Delete the last invoice.
- Click Finish.
- Go back into Enter Pending Invoices.
- Select the problem session ID.
- Click OK. The pending invoice window should open normally to full size. If it does not, there may be more invoices contributing to the problem. Repeat the steps, deleting the last invoice, until it is resolved.
- Re-enter the invoice that was deleted, if it is needed.
Alternative workaround:
Instead of deleting invoices, you can use just steps 1 through 4 to access your invoices. Then continue to use the new session ID from step 2 and select the problem session ID as an additional session each time you need to access the invoices from that session.
If you have the Pending System setting set to Single User:
- If you have no pending invoices (AP Inquiries, Invoice Inquiries, Pending Invoice Register to verify) and no other unposted invoices (see article How can I see if I have unposted invoices in Accounts Payable?), you can rename the new.api and create a new one (see article How do I rename a file using File Tools? and select the new.api as the file to rename).
- If you do have pending invoices but none are commitment/purchase order/subcontract related (AP Inquiries, Invoice Inquiries, Pending Invoice Register to verify) and you are ok with re-entering the pending invoices and you have no other unposted invoices (see article How can I see if I have unposted invoices in Accounts Payable?), you can rename the new.api and create a new one (see article How do I rename a file using File Tools? and select the new.api as the file to rename). If you do not want to re-enter the pending invoices and/or you have other unposted invoices, contact Sage 300 CRE Customer Support. We will request a copy of your data files for evaluation to determine how to fix.
- If you do have commitment/purchase order/subcontract related pending invoices (AP Inquiries, Invoice Inquiries, Pending Invoice Register to verify), contact Sage 300 CRE Customer Support. We will request a copy of your data files for evaluation to determine how to fix.