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Error: "Failed to retrieve data from the database"

Created on  | Last modified on 

Summary

I receive the message "Failed to retrieve data from database" when trying to use Crystal Reports in Sage 300 CRE.

Description

Cause

Incompatible Crystal Runtime Components installed.

Resolution

CAUTION: Sage support can't assist with third-party products, hardware, report customizations, or state and federal tax questions. Refer to our Scope of Support for more info. Contact your Sage business partner, network administrator, or accountant for assistance.

 

Remove and reinstall the SAP Crystal Reports runtime engine for .NET Framework for the correct version of Sage 300 CRE Accounting on the affected machine.

  • Sage 300 CRE Accounting version 17.1 installs v13.0.19.2312 of the SAP Crystal Runtime
  • Sage 300 CRE Accounting version 18.1 installs v13.0.19 of the SAP Crystal Runtime

Run the SAP Crystal Runtime installer for versions 17.1 and higher. Locate it on the Sage 300 CRE server:

  • \\[ServerName]\TIMBERLINE OFFICE\9.5\Accounting\WinInst\Prerequisites\Crystal Runtime Engine (x86)\CRRuntime_32bit_13_0_19.msi

Once you've resolved this problem, confirm you can print Crystal-based reports in Sage 300 CRE. If you're still unable to run standard Sage Fixed Assets reports, refer to Crystal Runtime Version Conflict.

 

 

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