Skip to content
logo Knowledgebase

Error: "Failed to retrieve data from the database"

Created on  | Last modified on 

Description

Cause

Incompatible Crystal Runtime Components installed.

Resolution

CAUTION: This solution requires advanced knowledge of Windows security and network settings. Sage isn't responsible for any issues that may arise from changes to these settings. Back up all system and application databases needed for a complete restoration. Consider contacting a certified consultant or your system administrator for assistance.
CAUTION: This solution needs advanced Operating System knowledge. Consult your system administrator for help. Sage isn't liable for issues caused by improper changes to the Windows Registry. Always back up your data before applying advanced solutions.
CAUTION: Sage Customer Support cannot assist with issues related to third-party products or enhancements, hardware, report customizations, state or federal tax-related questions, or specific accounting questions. Refer to our Scope of Support document for details. For assistance, contact your Sage business partner, network administrator, or accountant. 

Remove and reinstall the prerequisite "SAP Crystal Reports runtime engine for .NET Framework" for the version of Sage 300 CRE Accounting installed on the affected machine.

  • Sage 300 CRE Accounting version 15.1 installs v13.0.8.1216 of the SAP Crystal Runtime
  • Sage 300 CRE Accounting version 16.1 installs v13.0.8.1216 of the SAP Crystal Runtime
  • Sage 300 CRE Accounting version 17.1 installs v13.0.19.2312 of the SAP Crystal Runtime
  • Sage 300 CRE Accounting version 18.1 installs v13.0.19 of the SAP Crystal Runtime

The SAP Crystal Runtime installer for v15.1 and v16.1 can be found at the following location on the Sage 300 CRE server:

  • C:\ProgramData\Sage\TIMBERLINE OFFICE\9.5\Accounting\WinInst\Prerequisites\Crystal Runtime Engine (x86)\CRRuntime_32bit_13_0_8.msi

The SAP Crystal Runtime installer for v17.1 and higher can be found at the following location on the Sage 300 CRE server:

  • C:\ProgramData\Sage\TIMBERLINE OFFICE\9.5\Accounting\WinInst\Prerequisites\Crystal Runtime Engine (x86)\CRRuntime_32bit_13_0_19.msi

Once this problem has been resolved and you can print Crystal-based reports in Sage 300 CRE, if you are unable to run standard Sage Fixed Assets reports refer to article 89033 "Error: Load report failed Running Standard reports".

DocLink: Error: "Failed to retrieve data from the Database" (Troubleshooting)
DocLink: Crystal Runtime Version Conflict
DocLink: What are the Crystal Runtime compatible versions of the recent releases of Sage 300 CRE, Sage Estimating, and Sage Fixed Assets?

Need more help?

Chat now