Error: "This task cannot be completed because it is a single-user task" but only one user logged in
Description
Cause
  • The company is not being opened from within the data path location
  • Computer was powered off, experienced a power outage or network disruption while working in Sage 50
  • Share permissions on the data location are incorrect
  • Using Paya Connect Desktop plugin for Invoice Payments
  • Remote user still connected or improperly closed out
Resolution
Section 1: User Login Manager

  1. Go to Maintain, Users, User Login Manager.
  2. Verify no other users are logged into the company and sign out any users that are.
  3. If the error still occurs, proceed to section the next section.

Section 2: Restart the Actian database

  1. Close Sage 50 on each workstation.
  2. Go to the server or computer that stores the data.
  3. Stop and then start the Actian service on the computer.
  4. Return to the workstation. Open Sage 50 and verify that you can complete your task.
  5. If the error continues proceed to next section.

Section 3: Company not in the data path

Confirm the company is within the correct data path. Refer to How to find data path and program path.

Section 4: Check for open files on the Server

  1. Browse to the data path on the server. Refer to How to find data path and program path.
  2. Press the Windows+R keys to open a Run line.
  3. Type fsmgmt.msc and press Enter.
  4. Select Open files.
  5. Locate any files open in the Sage 50 data path. If there are files open, right-click on them and select to close the open file(s).
  6. If the error still occurs, proceed to next section.

Section 5: Lock files and sharing configuration

  1. Go to the computer that stores the data.
  2. Stop the Actian service.
  3. Right-click on the shared data folder for Sage 50 and then select Properties.
  4. Select Sharing and then select Advanced Sharing.
  5. Clear the Share this folder box, and then click OK.
  6. Browse to the individual company's data folder. Refer to How to locate company directories.
  7. Delete any LCK and PTL files and COSESS.DAT in the directory.
  8. Re-share the same folder unshared earlier. Refer to Verify my data file permissions are correctly set.
  9. Start the Actian service.
  10. Verify on the workstation that you can complete your task.

Section 6: Using Invoice Payments (Paya Connect Desktop)

If using the Paya Connect Desktop plugin to do Invoice Payments, this program will act like a user in Sage 50.

  1. Right-click the Paya Connect Desktop (pcd) icon in the system tray, select Plugins, and select Off.
  2. Verify you can perform your single-user task.
  3. To re-enable the plugin, right-click Paya Connect Desktop in the system tray, select Plugins, and select On.

Section 7: Remote User

  1. Close Sage 50.
  2. Press Ctrl+Shift+Esc to open the Task Manager.
  3. Select the Details tab.
  4. Select Peachw.exe and then click the End Process button.
  5. Close Task Manager.
  6. Verify you no longer get the error.

Section 8: Happens on a workstation but not on the server

Test the network by using ping and tracert commands in a command prompt. If ping has packet loss or tracert response time shows greater than 1 or 2ms, consult a Network Administrator for assistance with your connectivity.


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