Slowness printing checks or other forms
Description
Cause
  • Large file size
  • Damaged form files
  • Large file size on a customized form
  • Incorrectly set sharing permissions or security
  • Logo customization too large
  • The inventory items being selected can be the culprit (try creating a new NonStock Item and test)
  • Print spooler has high CPU usage
Resolution

Section 1: Remove temporary printer files from your Forms folder

  1. Go to Maintain, Company Information and note the company's directory.
  2. Close Sage 50 on all workstations.
  3. Browse to the folder before your companies directory usually a folder labeled "Company". Browse to the Forms folder in there.
  4. Remove any .ptr files from this folder by cutting them out of the folder.
  5. Reopen Sage 50 and verify that you can now print/email correctly.

Section 2: Sharing Permissions/Security

Note: This section only applies if Sage 50—U.S. Edition is being used on a network

  1. Try printing the same transaction at the server.
  2. If the form prints quickly, check your sharing settings. See Verify my data file permissions are correctly set.
  3. If the form prints slowly, continue to the next Section.

Section 3: Damaged Form Files

Print a transaction using a standard form if the standard form prints quickly:

  1. Select Reports & Forms, then Forms.
  2. Select the form type for the transaction that is printing slowly.
  3. Find the customized form in question (customized forms are indicated by a wrench icon next to the form title), right-click it, and select Save As.
  4. Enter a unique name for the form.
  5. Click Save.
  6. Right-click the original form and select Delete.
  7. Right-click the copied form and select Save As.
  8. Enter the name of the original form and click Save.
  9. Right-click and Delete the copied form.
  10. Verify that the transaction using this form will now print.

Note: If you have a backup made before the issue started, you can restore your custom forms from it. See Custom forms are missing. If you do not have a backup, you must use the steps above or recreate the form. For assistance re-creating the form, see How to customize forms.

If the standard form also prints slowly:

  1. Close Sage 50.
  2. Open My Computer or Computer and browse to your data path; see How to find data path and program path.
  3. Right-click the Forms folder and select Delete.
  4. Run the Repair for Sage 50; see How to run Repair.
  5. When Repair completes, open the Updates folder in the data path and run the most recent service release.
  6. Open Sage 50 and print a transaction using a standard form; it now should print quickly.
  7. Restore your custom forms from a backup made before the slowness started. See Custom forms are missing.

Section 4: Custom Form Size

If your customized form contains an image, and still prints slowly after the preceding steps, it is likely that the form's file size is causing the printing delay. Tips to reduce the image size, which in turn will reduce the form file size:

  • Saving your image file as a .GIF or .JPG will typically reduce the size
  • If your image is larger than you need on the form, re-size it outside of Sage 50 and save it as a separate file, then add the re-sized image to the form, rather than resizing it on the form customization window
  • If you do not have a color printer, convert your image file to grayscale or black and white

Note: The steps in Section 3 should resolve form size issues as well.

Section 5: Expendable file cleanup

Refer to Create a clean data folder and expendable file cleanup.

Section 6: Spooler SubSystem App high CPU usage

  1. Press Ctrl+Alt+Del and select Start Task Manager.
  2. If Spooler SubSystem App shows high CPU / memory usage, click the Services tab, then click the Services button at the bottom.
  3. On the Services window, find the Print Spooler service. Right-click it and select Restart.
  4. Close the Services window and the Task Manager. Open Sage again and try printing again.
  5. If the Spooler SubSystem App continues to show high CPU usage, contact your local IT to diagnose issues with the print spooler.
Steps to duplicate
Related Solutions