INTERNAL: Contract totals are incorrect
Description
Cause
The application terminated unexpectedly during posting and the totals did not update
Resolution
[BCB:1:Backup warning:ECB]

 

 

Use the Cn.exe backdoor tool

Before using the backdoor tool - verify that the contract item links on the change request are correct and verify that the price markups, taxes, or add-ons have the correct Contract Item and do not have the Exclude from Contract check box selected as follows:

Confirm the amount is stranded in Contracts:

  1. From the Project Management Contract Control menu, select Change Orders.
  2. Select the first change order for this job.
  3. Clear the Revise Contract check box and click Save.
  4. When prompted for the reversing transaction date, click OK.
  5. Repeat steps 2 and 3 for all change orders for this contract.
  6. In Contracts, go to Inquiry, Contract/Item Inquiries, Derived Totals. Select Active and click OK twice. Condition or find the contract. The original contract and Revised contract columns at both the contract and contract item should be the same and the approved contract changes should be blank. If they do not match, it is a contract backdoor scenario. If they do match, then it could be an exclude from contracts issue or a contract item link issue. See articles and steps below for more information.

Confirm the Exclude from Contracts is not selected:

  1. In Project management, from the Contract Control menu, select Change Requests.
  2. Click Find and select the job and change request.
  3. Click the Price/Cost Estimate tab.
  4. If you have price markups, taxes or add-ons, verify that the Contract item is correct in the lower grid.
  5. If there is no Contract Item column, right-click in the lower grid and select Hide/Show Columns.
  6. Select the Contract Item and Exclude from Contract check boxes, and then click OK. Make sure the correct contract items are referenced and the Exclude from Contract check box is not selected.
  7. Click Close.

 

Follow the steps below to use the tool.

  1. Have all operators exit Sage 300 CRE.
  2. Backup your Data Folder.
  3. Log on as an Application Administrator (full access) to the Sage 300 CRE Data Server.
  4. Close any instances of Contracts.
  5. Open the Cn.exe backdoor utility.
    1. Click Start on your Windows menu.
    2. Select Run.
    3. In the Open box, type cn.exe backdoor.
    4. Click OK. Contracts opens automatically.
  6. Enable Audit Setup Activity (Tools, Options).
  7. From the File menu, select Open Contract, select the contract ID, and then click OK twice.
  8. Change the totals.
    Tip: If you update the Contract Totals, type the correct totals on the contract item, then type the totals for the Original, Approved changes, and Revised columns on the main contract. If you do not manually update the contract total amounts, the system attempts to auto-correct the totals on the contract. If this occurs you must type the correct totals.
  9. Close the contract. The totals save automatically.
  10. Disable Audit Setup Activity (Tools, Options) after verifing the contract totals are correct by checking the Revise Contract check box on the change orders in PJ.
  11. Exit the Contracts application.

Note: Check the totals from change orders.

DocLink: Contract change order totals are wrong due to changes from Project Management
DocLink: Why does my Project Management change order have a different amount in Billing or Contracts? (Wrong contract item)
DocLink: The change order amount in Contracts is different than the amount of the change order in Project Management (Exclude from Contract)



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