Error: "STOP! Another user has locked a portion of the data file..."
Description

Full error message

STOP!

Another user has locked a portion of the data file required by this task. The update operation is unable to complete. Please continue to select Retry.

Support Information:
Blocked by [user],
[path to the server], Log record (1).

Retry Status:

Cause
  • Pervasive/Actian has locked the file
  • A large QLM file can cause file locking
Resolution

Complete the steps outlined below until you resolve the error. When the error no longer occurs, check your accounting data and confirm that entries posted and your totals are in balance.

File locked

  1. Have all users close out of Sage 300 CRE and click Retry.
  2. If you can continue processing your task, you don't need to complete the other steps. If the message persists, continue to step 3.
  3. Click the Abort button.
  4. You'll receive a message to restore from backup or that the QLM file is corrupt. The application closes. You do NOT need to restore from backup or run File Doctor.
  5. Restart the workstation where this error occurs.
  6. Test the task again. If the error continues, work with your IT professional to unlock files on the server.

Large log file

If the issue persists, contact your IT professional to evaluate the Sage 300 CRE log file and archive if needed.

  1. Check the size of the Log Viewer file (master_qlm folder in the \Timberline Office\9.5\Accounting\Global\PVData folder).
  2. If the file is more than 2GB in size, archive or move the QLM files.

 

[BCB:156:Chat 300 CRE US:ECB]
Steps to duplicate
Related Solutions

Common issues caused by a large Log Viewer file (QLM)