How to install Sage Timeslips on a Windows peer-to-peer server
Description
Cause

Since some offices may not have a dedicated machine for a standalone file/application server, Sage Timeslips can be installed and configured on machines using a Windows desktop operating system to act as the server while also allowing use as a workstation simultaneously. Please note that using Sage Timeslips on the workstation/server will also claim and hold a Sage Timeslips license.

Resolution
[BCB:3:Network warning:ECB]


 

Summary of Steps

  1. Create a network share for Sage Timeslips
  2. Install Sage Timeslips Premium to the network share
  3. Perform local installs to your Sage Timeslips Premium workstations

Create a Timeslips Premium Share

  1. On the Sage Timeslips server, from the Windows Start menu, select Computer.
  2. Double-click the drive you want to create the shared volume on. The C: drive is commonly available to install to.
  3. Click File, New, Folder. Name the folder TSSHARE.
  4. Right-click the TSSHARE folder and select Share, Advanced Sharing or Share, Share with Specific People.
    • Set up the proper permissions and users for this shared volume. By default, Windows assigns minimal rights to new shared volumes. You must have and grant at least Read/Write permissions to this folder.
    • For Permissions, click Read and Write for the desired users or you can choose Everyone and mark them as Read/Write for a simplistic setup. Network administrators may choose to be more selective with specific users and specific permissions.

Outlined below is information on the differences between Read and Write rights.

Read

Read is the default permission that is assigned to the Everyone group. Read allows:

  • Viewing file names and subfolder names
  • Viewing data in files
  • Running program files


Write/Change

Write/Change is not a default permission for any group. The Change permission allows all Read permissions, plus:

  • Changing file names and subfolder names
  • Changing data in files
  1. Click OK on the Permissions window
  2. Click OK on the TSSHARE Properties window.

    The share should now be visible to other computers on the network.
  3. In some instances you may need to go into your Windows Network and Sharing section to enable File sharing and Network discovery. Go to Windows Control Panel, Network and Sharing on the left choose Change Advanced Sharing Settings. Make sure both File and printer sharing and Network discovery are turned on.
  4. If you have a firewall enabled, it is necessary to make sure that TCP port 3050 is open. The Firebird Database engine that Sage Timeslips Premium uses, transmits data to and from network machines via this port. If it is closed Sage Timeslips Premium will not be able to open databases on your server.

Note: To complete this setup, you must be sure of the server's name. To determine this name, right click My Computer and choose Properties to find the computer name.

Install Sage Timeslips to the Network Folder Share You Created Earlier

Sage Timeslips should be installed in a shared folder under the Local Volume (C: drive); for example, C:\TSSHARE\Timeslips or C:\APPS\Timeslips.

Server Considerations:

  • We do not recommend installing Sage Timeslips under the C:\Program Files\Timeslips on a server due to Windows limitations when accessing shared data under Program Files.
  • You must be physically at the server to perform this install; you cannot install TO the server from another network machine.
  • Make sure that your server is on the same network and visible to the local workstations.
  • Sage Timeslips communicates via port 3050. Make certain that port 3050 is open in your network firewall on the Application/Database Server only. This is not required on local install machines. You can review instructions on how to open a port by reading the document KB Article 63862 ' How to open port 3050 in Windows Firewall for Sage Timeslips Premium' in Related Resources below.
  • If you are on a monthly subscription and installing the Premium version, you must make sure you have an active internet connection to validate your account.

Finding the serial number, configuration code/activation key and account ID

You will need your serial number, configuration code/activation key and account ID to install Sage Timeslips, register Sage Timeslips, and to receive technical support (if necessary). Sage sent this information to you in an email message shortly after your order.

Understanding single-user configurations

When using Sage Timeslips, a single-user installation refers to any installation that has one station license. Some single-user installations include:

  • Single-user installation with one computer – If you purchased a single license of Sage Timeslips Premium and you own a single computer, the program files and database will reside on this computer.
  • Single-user installation on a network workstation with the database on a network workstation – If you purchased a single station license of Sage Timeslips and your workstation is connected to a network, you can install Sage Timeslips Premium on your local workstation and maintain your Sage Timeslips Premium database on that same workstation.
  • Single-user installation on a network workstation with the database on a network drive – If you purchased a single station license of Sage Timeslips Premium and your workstation is connected to a network, you will not be able to maintain a database across the network. Your Sage Timeslips Premium database must reside locally on hard drives on your workstation.

Understanding network configurations

If you purchased multiple Sage Timeslips station licenses, then multiple users (up to the number of station licenses purchased) can access the database simultaneously. To support multiple-user access, you must install Sage Timeslips Premium in a network environment. This section describes common network configurations:

  • Peer-to-peer networks – If your firm has workstations networked in a peer-to-peer environment (where workstations can access drives on other workstations), the first workstation on which you install Timeslips is considered the Timeslips Server.
  • Network installation – If your firm has network workstations and a network server (which contains shared network drives), you can install your initial Timeslips installation on the network server. In this configuration, the your firm’s network server is the Timeslips Server.

In network installations, after installing Sage Timeslips on the first computer, you can use the local installer to install Sage Timeslips to each network workstation that will access Timeslips. In Related Resources below, see KB article 63864: “How to Perform a Local Installation of Sage Timeslips Premium” for additional information about configuring your network workstations.

You can install Sage Timeslips in many network environments. Our online knowledgebase includes detailed installation instructions for some of these specific network environments. Please visit installation specific Knowledge Base articles at KB article 63919: 'Sage Timeslips Premium network installation guides' to access our online knowledgebase for installation guides.

  1. Download the Sage Timeslips installation file. If the installation process does not start automatically, start the installation by double-clicking on the Sage Timeslips download file. The download file will extract the necessary installation file and will open a menu of options.
  2. Launch the Sage Timeslips installation program.
  3. Choose to Install Sage Timeslips.
  4. During the wizard when asked if this is the Application Server or Database Server, choose Complete Server installation.
  5. Choose your network share that you set up previously in the above steps from the Create Timeslips Share steps.
  6. Once installation completes then your Application Server is installed.

On any computer that uses Sage Timeslips Premium, browse to the network share created in the previous section. If you use the server as a workstation, you do not need to perform these steps on the server. You may run and use Sage Timeslips Premium as installed on the server.

Perform Local Installs to your Sage Timeslips Workstations

  • Sage Timeslips Installed on server - If you followed these instructions to install Sage Timeslips directly on your server, it should now be configured to run Sage Timeslips. If you open Sage Timeslips on the server and select Help, About Timeslips, the Installation folder should be \\server_name\Timeslips and the Application folder should also be \\server_name\Timeslips


Now that Sage Timeslips is configured on the server, you can perform local installs to each of your workstations. On your workstation, perform a local installation. This is not necessary on the server itself.

  1. Click Start, and type \\server_name in the search box and press Enter. Be sure to type in the name of your server. The network share TSSHARE should be listed as a folder. If you do not get this result, make sure that you have shared TSSHARE properly and that you have the correct name of your Timeslips folder.
  2. Double Click TSSHARE.
  3. Open the Timeslips folder, then the LoclInst folder, and double-click on Setup.exe to start the installation.
  4. Upon starting the local installation, choose the desired installation type.
  5. Choose the location for Sage Timeslips. On 32-bit workstations, this is typically C:\Program Files\Timeslips\ and on 64-bit workstations, this is typically C:\Program Files (x86)\Timeslips\.
  6. After the installation is complete, start Sage Timeslips. Select Help, About Sage Timeslips.... The Installation folder should be \\server_name\Timeslips\ and the Application folder should be identical to the path specified in step 5 above.
  7. Perform this local install on each of your workstations.


[BCB:167:Chat Timeslips US:ECB] 





Steps to duplicate
Related Solutions

How to open port 3050 in Windows Firewall for Sage Timeslips
How to perform a local installation of Sage Timeslips
How to perform a multi-upgrade on Sage Timeslips
Sage Timeslips installation guides