Error: "Unable to Process the Lockfile" or "Printer not activated. Error code -30" after installing Windows Updates for Windows 10
Description
Cause
Windows Security Settings
Windows 10 Feature Update
Resolution
[BCB:4:Operating system warning:ECB] [BCB:5:Third-party support:ECB]
Note: This problem may also occur when the Windows 10 Anniversary Update, v10.0.14393 is installed by Microsoft.
Note: If printing to Paperless Office PDF was previously working on the workstation, but suddenly stopped, it is likely the problem occurred after Microsoft Windows Updates were installed. Some Sage 100 users on Windows 10 workstations (even those on the most currently supported versions) have reported that sometimes a Microsoft Windows Update will delete registry entries and programs. We have found that Sage 100 PDF Converter registry entries disappear or become affected, requiring reinstallation and verification that the registry entries are replaced by reinstallation.
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If the workstation's Windows Registry at "..\HKEY_CURRENT_CONFIG\Software" no longer contains a "Sage 100 PDF Converter" key, then:
Verify via the Windows machine's Control Panel, User Accounts, Change User Account Control Settings', User Account Control is set to "Never Notify"
Remove the Sage 100 PDF Converter printer (via the Windows machine's Control Panel, Devices and Printers)
Reinstall the converter with the PL_AdvancedOptions_Ui utility in Sage 100 (from File, Run, enter PL_AdvancedOptions_Ui and click OK, then select Install Converter)
Possible Workaround:
Note: The Windows, Control Panel, User Accounts setting of User Account Control (UAC) must be On at least Level One in order for this to work, preferably at "Never Notify". If a Program is run "As Administrator" on Windows 8 with UAC off, most functionality will be disabled.
Option I: Reinstall Sage 100 PDF Converter from Paperless Office Advanced Options
Right-click Sage 100 shortcut and choose "Run as Administrator" option
Log into Sage 100
Select File, Run from Sage 100 Toolbar
Type: PL_AdvancedOptions_Ui
Select OK
Select OK to select default date
Select 'Install Converter'
Exit Paperless Office Advanced Options and try printing to Paperless again
Option II: Configure Sage 100 to Run as Administrator
Right-click the Sage 100 shortcut
Select Properties from the right-click pop-up menu
Access the Compatibility tab
Select (check) the Run this program as an administrator check box
Note: If multiple users use this workstation, select Change Setting for all users and select (check) the Run this program as an administrator check box
Click OK to save changes
Option III: Set permissions for the following keys in the Registry (at the workstation level):
Click the Start button
Click Run, and enter Regedit
Access: "HKEY_CURRENT_CONFIG\Software"
Right-click Software key
Select Permissions
Select Full Control for Users listed in this box, and then click Apply