How to run the Custom Office utilities; Rebuild Customizer Log and Update Custom Panels to Current Level
Description
Cause

After a version upgrade of the Sage 100 product, standard change made to existing task windows, screens, and/or panels may be incompatible with customizations or modifications created via Custom Office, Customizer Selection in the previous version.

Resolution
[BCB:1:Backup warning:ECB]
[BCB:5:Third-party support:ECB]

Note: This requires use of the Custom Office module application (also known as Customizer). Not all installations of Sage 100 include this module.

Note: This is considered customization. Using the Custom Office application module requires knowledge and familiarity. Sage 100 Customer Support does not assist in creating customizations and may not be able to troubleshoot or resolve errors or issues that may arise from customizations (this also applies to custom scripts). If you encounter an error or issue, you may have to delete or remove the customization and start over. Therefore, you may want to get assistance from your local Sage business partner or a qualified consultant. There is also Customizer training available on Sage University (www.sageu.com).

Caution: Not all customization compatibility issues or errors will be resolved in this manner. As Sage continues to improve the product with each new version, some task windows, screens, and/or panels will have changes made to their layouts over the versions. Customization overlays that worked for a previous version may not be compatible with a newer version. If running the following utilities does not resolve the issue, it may be necessary to modify, or delete and re-create them.

To Rebuild Customizer Log:

  1. Open Custom Office, Utilities menu, Rebuild Customizer Log
  2. Click OK to run the Rebuild Customizer Log utility

To Update Custom Panels to Current Level:

  1. Open Custom Office, Utilities menu, Update Custom Panels to Current Level
  2. Click OK to run the Update Custom Panels to Current Level utility for all modules, tasks, companies, and users

Notes:

  • The Rebuild Customizer Log utility should be used after any *.LIB file is copied from the another installation's "..\MAS90\XX\Custom" folder (where XX is the application module code). This procedure writes the customizations to the Customizer Log File so that it can be used in the current installation.
    • Caution: Manually copying *.LIB or other files is not generally recommended.
  • The Update Customized Forms to Current Level utility merges the default changes to the form with the customized changes from the previous version. Run this utility whenever Sage MAS 90 or 200 is upgraded to avoid conflicts with any changes in the new version.
    • The update performs the following:
      • A new library file is created based on the current *.LIB file in the relevant "..\MAS90\XX\Custom" folder (where XX is the application module code)
      • The properties of each customized object on the form are updated to the new library
      • As each library is completed, the old customized library is removed and replaced by the new *.LIB file.
DocLink: How to install Sage 100 and locate installation and upgrade information
DocLink: Error: "65 SY_CommonUi.pvc XXXX" and "Windows element does not exist" occurs when accessing a task window or screen
DocLink: How to delete or reset a Custom Office task, screen, or panel customization

[BCB:155:Chat 100 US:ECB]
Defect ID
Steps to duplicate
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