Error: "An error occurred. Close and then re-open Sage Desktop. See the log for details."
Description
Cause
  • Corrupt or missing configuration files
  • Lack of Windows permissions
  • File locations that are pointing to an old server and are no longer available
  • User directory for Citrix server user is set to a temp directory
  • Corrupted files in two folders in %userprofile%\AppData\Roaming\IsolatedStorage
Resolution
[BCB:5:Third-party support:ECB]

 

For other possible causes and solutions, refer to Error: "An error occurred. Close and then re-open Sage Desktop. See the log for details." (MASTER ARTICLE)

This is a known issue in v16.1 prior to the release of Revision 6. The recommended fix is to upgrade to v16.1 Revision 6 or higher.

 

Option 1:

Close all open tabs within Sage 300 CRE desktop view and try to open security administration again.

Option 2:

  1. Navigate to C:\ProgramData\SAGE\General and rename the Locations.xds to Locations.old.
  2. Try opening Sage Desktop.

Option 3:

  1. Rename the "Sage_Inc" folder to "Sage_Inc_Renamed", located at %userprofile%\AppData\Local\Sage_Inc
    • Note: the "AppData" folder is hidden by default.
  2. Test to see if Sage Desktop now opens without error.

Option 4:

  1. Rename two folders underneath %userprofile%\AppData\Roaming\IsolatedStorage
    • C:\Users\{username}\AppData\Roaming\IsolatedStorage
    • Folders beginning with Publisher and StrongName

Option 5:

  1. Right-click the Sage Desktop icon and select Run As Administrator.
  2. Click Yes to get past any User Account Control (UAC) screens, to allow Desktop to run.
  3. If the UAC prompts to enter an Administrator login to open Desktop, you might need to turn off the UAC. See How to disable User Account Control (UAC).

Option 6:

  1. Completely remove and reinstall the Sage 300 CRE Client on the affected workstation. See How do I remove Sage 300 Construction and Real Estate client from a workstation?

Option 7:

  1. Close out of Sage on the workstation.
  2. Right-click on the ORIGINAL Desktop icon and Unpin from task bar.
  3. Open File Explorer and go to C:\Program Files (x86)\Timberline Office\Shared.
  4. Double-click on desktop.exe.
  5. Right-click on the icon in their Task Bar and choose Pin to Task Bar.
    Note: You will need to unpin this icon and re-pin the new Desktop Icon using DESKTOP.exe located at C:\Program Files (x86)\Timberline Office\Shared after upgrading to 16.1 Rev 6.

Option 8:

  1. Check Windows permissions on company data folder for full control for the Sage users group.
    1. To test, you can add the Everyone group for full control and propagate to all child folders, it is likely the permissions look correct but are not propagated to Child folders.
    2. Test with opening Sample Data, Sample Data is in the \\server\Timberline Office\Data folder, the company data may be on another partition or share.
    3. Also check permissions on the 9.5 folder located at \\server\Timberline Office\9.5.

Option 9: Occurs when opening a particular company from Sage Desktop (Does not with all companies or Sample data)

  • Verify user has at least Read\List access to Import type directories and Modify access to any other directories listed in File Locations
  • If the windows event viewer lists an error for "System.InvalidOperationException: Handle is not initialized", this may indicate a permissions issue.
  1. Log into Sage 300 CRE Desktop.
  2. Select Sample Company or any company that does not produce error.
  3. Open Common Tasks, File, Company Settings, File Locations.
  4. Verify the user(s) can access each directory in list.
  5. Update permissions to any folder user(s) can't access.

Option 10 (only applies to version prior to v16.1 Revision 6):

  1. Close all Sage applications on the affected machine. Make sure the option Hide extensions for known file types is not enabled in Windows Explorer options.
  2. Navigate to C:\Program Files (x86)\Timberline Office\Shared\ and rename the Dragablz.dll file to Dragablz.old.
  3. Download the attached Dragablztxt.zip file and unzip the Dragablztxt file.
  4. Rename the Dragablztxt file to Dragablz.dll and copy this newer Dragablz.dll file into the \Shared folder to replace the original file renamed in the previous step.

Attachment: Dragablztxt.zip

[BCB:156:Chat 300 CRE US:ECB]

Steps to duplicate
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