How do I control what gets logged in the log viewer?
Description
Cause

The Sage 300 Construction and Real Estate log viewer records entries for application tasks and system events. Over time these entries can cause the log to grow to tremendous sizes, causing system slowness or instability. See article Log In/Out entries from interfacing software are filling the Sage Log Viewer

You can archive and delete log entries to help control the size of the log. See article How to archive the Log Viewer

You can also control which types of events get logged to the log viewer, in case you are only interested in logging certain types of events. This will also reduce the size of the log and the speed at which it grows.

Resolution

[BCB:1:Backup warning:ECB]

 

IMPORTANT: To slow the growth of the file, it is recommended to turn off (unmark) logging for the Security log type in the Log Settings. This will stop the recording of the log in/out entries.

  1. To turn on or off logging event types, open the Log Viewer. The log viewer can be accessed in one of the following ways:
    • Version 15.1 and older:
      • From Desktop: Tasks pane, Common Tasks, Tools, Log Viewer
      • From within an application: Tools, Log Viewer
    • Version 16.1 and newer:
      • From Desktop: Applications, Common Tasks, Tools, Log Viewer
      • From within an application: Tools, Log Viewer
  2. Click the Settings button on the top tool bar of the log viewer.
  3. The Settings window shows you the event types that are logged in the log viewer with a short description:
  4. To turn off logging of one event type, uncheck that type. To turn logging on for one type, check that type.
    Note: If you turn off logging for an event type, then no message or event of that type will be logged.
  5. Click OK to save changes and return to the log viewer.



[BCB:156:Chat 300 CRE US:ECB]

Steps to duplicate
Related Solutions

Issues caused by a large Log Viewer file (QLM)