Error: "Payment could not be written to disk" (AP check number has been previously used)
Description
Cause
The check number had already been used.

This issue can occur depending on your settings and check numbering. For example, this message appears when you try to print check number 1171 when check number 1172 and 1173 have previously been used. If you are paying many invoices, and the Payment Stub Settings in Setup, Vendors, Payment Settings tab is set to List all invoices on stub, check 1171 is available but the task needs to void the next check numbers (checks 1172 and 1173) to use the stubs to list the additional invoices.
Resolution

Change the vendor's Payment Stub Settings (Setup, Vendors, Payment Settings) to Summarize on stub or Conditional, then only one check prints for all invoices. Use the extended stub report (printed with the Payment report during Print Checks) for a listing of invoices paid on the check.

Steps to duplicate
Related Solutions

Error: "Payment could not be written to disk" (AP broken distribution records)

Error: "Payment could not be written to disk" (AP invoice is missing distribution information)

Error: "Payment could not be written to disk" (CM Edit Register open)

Error: "Payment could not be written to disk" (in AP Record Manual/Print Quick Checks)