Summary
How to resolve this error, which occurs when opening Sage 50.
Cause
- The latest Service Release wasn’t installed
- ActiveX controls blocked in Internet settings
- Not installed in the Program Files (x86) directory on a 64-bit computer
- Invalid program path files
- Damaged or incomplete installation
- User Account Control (UAC) settings
Resolution
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To manually download the Product and Services (P&S) update, open a Sage 50 company and select Services, Check for Updates, Check Now. Since P&S updates normally install without any user interaction, you could see the message "There are no updates available at this time." Click OK on the message, then close the Sage 50 application and reopen to install the P&S update.
Install the latest Service Release
- Open Sage 50—U.S. Edition.
- Select Services, Check for Updates, and then select Check Now.
- Select Download.
- Close Sage.
- Service Release will now install.
- Verify you get no errors when opening Sage.
Sage Advisor settings
- Open Sage 50.
- Select Help > Sage Advisor > Settings.
- Uncheck all the boxes and click OK.
- Close Sage for the changes to take effect.
- Open Sage.
- Open a Maintenance screen and verify you no longer get an error.
Install on a 64-bit computer
Note: If you have a 64-bit computer, you will need to verify the program is installed in the Program Files (x86) directory. The program path, for example, should look like this: PROGRAMPATH=C:\PROGRA~2\Sage\PEACHT~1\.
- To check the current installed program path, see How to find the data path and program path.
- If your program path doesn’t look similar to the sample above, uninstall the program.
- Reinstall the program, being careful to select the Program Files (x86) directory for the program files.
Damaged or incomplete installation
- Close Sage.
- Browse to the program path, see How to find the data path and program path.
- Rename the PTToday folder to OLDPTToday.
- Rename the ProductServices folder to OLDProductServices.
- Run Repair. See How to run Repair.
- Disable any antivirus and reinstall the latest Service Release. See How to install updates.
- Verify Sage opens without error.
Disable User Account Control (UAC)
- Disable UAC. See How to disable User Account Control (UAC).
- Verify you no longer receive the error and that you can pay multiple employees.
Rename UserPref.dat
Rename UserPref.dat. See How do I reset the user preferences for my company?
If you’re also seeing the error "Assertion Failed: System.IO.FileLoadException: Retrieving the COM class factory for component with CLSID {22743F12-6056-4120-A3FE-98200361EF91} failed due to the following error: 80131040." after going through the Script Error, refer to Error: "Assertion Failed, Abort, Retry, Ignore" when opening.
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