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Error: "An error has occurred in the script on this Page"

Created on  | Last modified on 

Summary

How to resolve this error, which occurs when opening Sage 50.

Cause

  • The latest Service Release wasn’t installed
  • ActiveX controls blocked in Internet settings
  • Not installed in the Program Files (x86) directory on a 64-bit computer
  • Invalid program path files
  • Damaged or incomplete installation
  • User Account Control (UAC) settings

Resolution

 NOTE: On September 11, 2024, there were widespread reports of "an error has occurred in the script on this page" when opening Sage 50. The error popped up each time when opening or changing a company.  The issue has been resolved via a Product and Services (P&S) update on September 17, 2024. See below for instructions on how to manually download the update if you don’t want to wait for it to be automatically downloaded and installed.
 
To manually download the Product and Services (P&S) update, open a Sage 50 company and select Services, Check for Updates, Check Now. Note that since P&S updates normally install without any user interaction you may see the message "There are no updates available at this time." Click OK on the message, then close the Sage 50 application and reopen to install the P&S update.

Option 1: Install latest Service Release

  1. Open Sage 50—U.S. Edition.
  2. Select Services, Check for Updates, and then select Check Now.
  3. Select Download.
  4. Close Sage.
  5. Service Release will now install.
  6. Verify you get no errors when opening Sage.

Option 2: Sage Advisor

  1. Open Sage.
  2. Select Help, Sage Advisor, Settings.
  3. Uncheck all the boxes and click OK.
  4. Close Sage for the changes to take effect.
  5. Open Sage.
  6. Open a Maintenance screen and verify you no longer get an error.

Option 3: Install on a 64-bit computer

Note: If you have a 64-bit computer, you will need to verify the program is installed in the Program Files (x86) directory. The program path, for example, should look like this: PROGRAMPATH=C:\PROGRA~2\Sage\PEACHT~1\.

  1. To check the current installed program path, refer to How to find the data path and program path.
  2. If your program path doesn’t look similar to the sample above, uninstall the program.
  3. Reinstall the program, being careful to select the Program Files (x86) directory for the program files.

Option 4: Damaged or incomplete installation

  1. Close Sage.
  2. Browse to the program path, refer to How to find the data path and program path.
  3. Rename the PTToday folder to OLDPTToday.
  4. Rename the ProductServices folder to OLDProductServices.
  5. Run Repair, refer to How to run Repair.
  6. Disable any antivirus and reinstall the latest Service Release, refer to How to install updates.
  7. Verify Sage opens without error.

Option 5: Disable User Account Control (UAC)

  1. Disable UAC, refer to How to disable User Account Control (UAC).
  2. Verify you no longer receive the error and that you can pay multiple employees.

Option 6: Rename UserPref.dat

Rename UserPref.dat, follow How do I reset the user preferences for my company?

If you’re also seeing the error "Assertion Failed: System.IO.FileLoadException: Retrieving the COM class factory for component with CLSID {22743F12-6056-4120-A3FE-98200361EF91} failed due to the following error: 80131040." after going through the Script Error, refer to Error: "Assertion Failed, Abort, Retry, Ignore" when opening.

 

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