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Payments crash the program

Created on  | Last modified on 

Summary

When entering Payments in Sage 50 Accounting, the program crashes randomly. Or, tabbing through entry screens crashes the program.

Cause

  • Damaged files in the company directory
  • Tablet PC services, Touch Keyboard and Handwriting panel service enabled

Resolution

Workaround: Maximize the entry screen window

  1. Click the Maximize (square) button on the upper right of the entry screen window to enlarge it to fit the entire screen.
    • Alternately, press Alt + Spacebar with the window open and select Maximize
  2. Enter your transaction and verify that the error no longer occurs. If the error still occurs, proceed to the next section.

Run Sage 50 as administrator

  1. Close Sage 50.
  2. Right-click the Sage 50 Accounting icon and select Run as administrator.
  3. Test entering a payment.

If you're able to enter a payment without error when running as administrator, you can set the program shortcut to always run as administrator:

  1. Right-click the Sage 50 Accounting icon and select Properties.
  2. Select the Compatibility tab.
    • If the program is running in compatibility mode for Windows 8, clear the compatibility mode box. If it isn’t running in compatibility mode for Windows 8, then select the box
  3. Select the box to Run this program as an administrator.
  4. Click OK.
  5. Open Sage 50 and verify that you’re able to enter payments successfully. If the error still occurs, proceed to the next section.

Delete registry key

  1. Close Sage 50.
  2. Press the Windows+R keys and type regedit, and then click OK.
  3. Browse to HKEY_CURRENT_USER\Software\Peachtree\Version\[Release Number].
    • Release 2026: 33
    • Release 2024: 31
    • Release 2023: 30
    • Release 2022: 29
  4. Delete the Positions key and close the Registry Editor.
  5. Press Ctrl + Shift + Esc on the keyboard to open the Task Manager.
  6. On the Task Manager, click the Details tab.
  7. Find TabTip.exe, select it, and click End Task.
  8. Open Sage 50 and verify the program no longer closes when entering payments. If the error still occurs, proceed to the next section.

Disable Tablet PC Input Service

  1. Close Sage 50.
  2. Press Ctrl + Shift + Esc on the keyboard to open the Task Manager.
  3. On the Task Manager, click the Details tab.
  4. Find TabTip.exe, select it, and click End Task.
  5. Open Device Manager in Windows. Double-click Human Interface Devices to expand it.
  6. Right-click "HID-compliant touch screen" and disable it.
    • If "HID-Compliant touch screen" isn't present, look for Intel Precise Touch and Stylus driver
  7. Open Sage 50 and verify the program no longer closes when entering payments. If the error still occurs, proceed to the next section.

Damaged DDF and/or User Preferences

  1. Close company on all computers.
  2. Browse to the company directory. See How to locate company directories.
  3. Rename UserPref.DAT in the company directory to OldUserPref.DAT.
  4. In the same directory, delete any files ending in the extension DDF.
  5. Open the company and confirm that you can save and print payments successfully. If the error still occurs, proceed to the next section.

Damaged Data

  1. See How do I run the Vendor/Journal Synchronization Test?
  2. If the program still crashes, see How do I load, access, and run Data Verification? If the error still occurs, proceed to the next section.

User Account Control (UAC) settings

  1. Disable your UAC. See How to disable User Account Control (UAC).
  2. Open Sage 50 and verify the program no longer closes. If the error still occurs, proceed to the next section.

Disable Sage Advisor

  1. Go to Help > Sage Advisor > Settings.
  2. Uncheck all checkboxes and click OK.
  3. Close and reopen Sage 50 and verify that the error no longer occurs. If the error still occurs, proceed to the next section.

Using a Surface Pro tablet

See Crashes when saving transactions on a Surface Pro tablet.

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