Summary
The Status 3000 and 7033 errors indicate network or connection issues related to the database or the application interacting with it. This means there's a problem with the connection to the database server, either locally or remotely.
Cause
The workstation or computer lost connection to the server.
Resolution
Antivirus and backup software
- Ensure that the automatic backup on the server runs when no users are in Sage BusinessWorks.
- Backup software or imaging software also causes this issue. Uninstall the backup or imaging software.
- Configure your antivirus software to exclude Sage BusinessWorks files with the file extensions *.mkd and *.ddf.
- Exclude the Pervasive or Actian folder within the Program Files or Program Files (x86) folder on each workstation and the server.
NOTE: Often, the antivirus AutoProtect feature is unable to keep up with the volume of files accessed on the network and the connection times out. Configuring the antivirus utility to exclude Sage BusinessWorks files helps prevent this.
- Remove the McAfee Privacy Service using the Add or Remove Programs option in the Windows Control Panel if it’s installed.
Release connections to database and empty TEMP folder
- There’s a stranded task in the Sage BusinessWorks program. Release or disconnect users or tasks.
- Reboot the workstation receiving the error.
- If the 3006 error occurs on a standalone machine or at the server, empty the TEMP folder
NOTE: There are two temp folders. The c:\Users\[user]\AppDataLocal and c:\windows.
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f the error is a 3112 followed by a 3111, uninstall the database engine and reinstall Sage BusinessWorks and Service Packs.
Network connectivity
CAUTION: The suggestions below require advanced knowledge of your network. Contact your system administrator for assistance. Modifying Windows security incorrectly can severely affect system operations. Sage isn’t responsible for operation issues caused by incorrectly modifying your Windows security.
- If using a wireless router, disconnect and reconnect using a direct connection.
- If running in a virtualized environment using Microsoft's Hyper-V virtualization and have a Broadcom Gigabit Network Adapters, check the setting for Virtual Network Queues.
- This setting defaults to Enabled. Setting to Disabled could speed things up dramatically
- Disabling the power management settings in the bios shows a positive improvement on performance
- Another setting to check in a virtualized environment is the power management settings
- If using VMware, disable LRO in a VMXNET3 network adapter. On Windows, the LRO technology is also referred to as Receive Side Coalescing (RSC).
NOTE: Search Microsoft help for information on How to Enable or Disable LRO on a VMXNet3 Adapter on a Windows Virtual Machine.
- Review the server and workstation system and application logs for the reasons the disconnects occur.
- Items to look at include hardware, such as network cards (on the server and workstations), network cables, routers, switches or hubs or other connection issues
- Issues occur in an untold number of places because networks are an intricate and complex web of connections. Provide the suggestions below to your network technician to help troubleshoot the issue.
- When the error occurs, does the issue affect one workstation or all workstations?
- If the issue affects one workstation, it’s environmental specific to that workstation. Check all the network hardware; NIC, cable, ports, and so on
- If the issue affects all workstation, check the server NIC, switching equipment, and so on
- How often does this issue occur?
- If this issue occurs at about the same time of day, what time does it occur? Is there a backup program, a download from the internet, or another application that starts then
- If this issue occurs periodically, have the network technician employ a packet sniffer or use one of the Sysinternals applications for monitoring network connections
- Check if anything is blocking or closing Ports 3351 and 1583, or if another process starts at the time of the disconnect
- When the error occurs, does the issue affect one workstation or all workstations?
- Make sure that all client workstations are on the same Virtual local area network (VLAN) as the server.
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