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Error: "Sage 300 ERP UI Container has stopped working" when previewing reports

Created on  | Last modified on 

Summary

Error: "Sage 300 ERP UI Container has stopped working" when printing reports to preview.

Cause

The most likely causes are:

  • The computer is missing Windows .NET Framework 3.5 
  • Another program also uses Crystal Reports, and the two programs use different versions
  • a4wcrinterop.dll isn't registered

 

Resolution

Install the latest Windows Updates

  • Ensure all computers have the latest Windows Updates

Check whether the machine has Windows .NET Framework 3.5 available.

.NET 3.5 is no longer the most recent version. If Windows updates disable .NET 3.5, you need to enable it:

  1. Open the Control Panel, Programs and Features, then Turn Windows Features on or off.
  2. Select .NET Framework 3.5
  3. Reboot the computer.

Workstation

Image

Server

Image

 

Check for a conflicting version of Crystal Reports.

Each machine uses a Crystal Reports print engine or runtime to print and preview reports. All programs that use Crystal Reports must use the same version of Crystal Reports.
  1. Open Control Panel, Programs and Features.
  2. Look for programs with Crystal in their name.
  3. Look for other programs likely to print complex documents.
  4. Identify programs that also use Crystal Reports, then consult the IT team to review available options.
  • Move the other program to a different computer.
  • Find the exact version of Crystal that each program is using. Then determine whether to upgrade the other program to match the Sage 300's Crystal version.

Try to register a4wcrinterop.dll.

  1. Log in to the server or workstation with Administrator permissions.
  2. Open the command prompt window.
  3. Enter the command C:\Windows\Microsoft.NET\Framework\v4.0.30319\regasm /register [sage300runtimefolder]\a4wcrinterop.dll.
    1. [sage300runtimefolder] is the location where you installed Sage 300, local drive or UNC.
    2. If the path is long, enclose it with double quotes.

If registering doesn't solve the problem

  1. Log in with Administrator permissions.
  2. Uninstall and reinstall System Manager. 
  3. Apply the latest Sage 300 product updates.

Reinstall Sage 300 program

As a last resort, reinstall Sage 300 and apply the latest product updates.

 

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Related Solutions

Error: "There was a problem registering the assembly a4wcrinterop.dll during installation".
The program hangs after closing the print preview window.
Error: "RegAsm: error RA0000: Could not load file or assembly".
What version of the Crystal reports print engine that Sage 300 supports?