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Error: "Sage 300 ERP UI Container has stopped working" when printing reports to preview

Created on  | Last modified on 

Cause

The most likely causes are:

  • The computer is missing Windows .NET Framework 3.5 
  • Another program also uses Crystal Reports, and the two programs use different versions
  • a4wcrinterop.dll is not registered

 

Resolution

There are several possible fixes for this message.

  • First, ensure all machines have the latest Windows updates
  • After you try a fix, try to print the report again

 

Option 1: Check whether the machine has Windows .NET Framework 3.5 available.

.NET 3.5 is no longer the most recent version. As a result, Windows updates may disable it.

To enable it, open the Control Panel and go to the Features list, as shown below. Re-choose .NET Framework 3.5. Depending on your version of Windows, your features list may look slightly different.

Workstation

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Server

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Option 2: Check for a conflicting version of Crystal Reports.

Each machine prints and previews using a Crystal Reports print engine or runtime version. If two or more programs use Crystal Reports, they must use the same version. 

  1. Open Control Panel, Programs and Features.
  2. Look for programs with Crystal in their name.
  3. Look for other programs likely to print complex documents.
  4. If you find programs that could also be using Crystal Reports, consult with your IT team about your options:
    1. Move the other program to a different computer.
    2. Find the exact version of Crystal that each program is using. Then explore whether you can upgrade the other program to match 300's version.

 

Option 3: Try to register a4wcrinterop.dll.

  1. Log in to the server or workstation with Administrator permissions.
  2. Open the command prompt window.
  3. Enter the command C:\Windows\Microsoft.NET\Framework\v4.0.30319\regasm /register [sage300runtimefolder]\a4wcrinterop.dll.
    1. [sage300runtimefolder] is the location where you installed Sage 300, local drive or UNC.
    2. If the path is long, enclose it with double quotes.

If registering does not solve the problem:

  1. Log in with Administrator permissions.
  2. Uninstall and reinstall System Manager. See the steps below.
  3. Apply the latest Sage 300 product updates.

As a last resort, reinstall Sage 300.

 

How to: Uninstall & reinstall System Manager 
Error: "There was a problem registering the assembly a4wcrinterop.dll during installation."
Program hangs after closing the print preview window
Error: "RegAsm: error RA0000: Could not load file or assembly"
What version of Crystal reports print engine is supported for Sage 300?

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