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Transaction number sequencing not advancing properly

Created on  | Last modified on 

Summary

Transaction number sequencing isn't advancing properly in Sage 50 Accounting. Purchase order, sales order, invoice, check numbering is incorrect.

Cause

  • Using the wrong copy of a company
  • Damaged files
  • The company has already used that check number

Resolution

Reference number already used

Search for the reference number to see if it is in use. The system won't automatically assign the same reference number twice.

  1. Go to Edit, Find Transactions.
  2. Set the date range to the beginning of the company up to today.
  3. For Reference Number, select Range, and enter a current invoice number in the From and To fields.
  4. Click Find.

If it finds a transaction already using the reference number, that’s why Sage 50 skipped the number. As a workaround, use a different number sequence.

You can also purge data from past years to remove the old transactions, which will free up those reference numbers for use again.

Damaged files

  1. Browse to the data path.
  2. Open the Forms folder.
  3. Delete/rename all files ending of the type PTR.
  4. Open the individual company folder.
  5. Delete/rename all files of the type PTR, MKD, and DDF.
  6. Verify that the number sequencing advances properly on all machines.

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