Processing Collaboration gets stuck in a loop when sharing a company on Remote Data Access
Description
The problem can manifest itself in several ways:
Loops back and forth between "Please wait while we set up your company for collaboration" and "Downloading from Remote Data Access”
Loops back and forth between "Sage 50 is currently processing a data bundle for upload to Remote Data Access" and "Downloading from Remote Data Access" when trying to resume sharing of a paused company
Loops back and forth between "Processing Remote Data Access Data Bundle” and "Downloading from Remote Data Access"
Error: "The company backup failed to upload to Remote Data Access"
"Downloading from Remote Data Access" flashes during data upload
“Please wait while we setup your company for collaboration”
Cause
Damaged / incorrect files in the company folder.
Resolution
Section 1 - Delete SyncState.txt
Note: Do not delete SyncState.txt when the company is already successfully in a shared state, as this could lead to data loss. It is perfectly safe to delete if the company is not currently shared.
If currently stuck in this loop, open the Task Manager and end task on Sage 50 Accounting to close it out.
Attempt to share (or resume) the company again. Note: You may receive "An error occurred synchronizing with Remote Data Access. This company is not synchronized and will close in one minute." If this occurs, close the program, reopen it, and try sharing again.
If the problem is not resolved, proceed to Section 2.