Processing Collaboration gets stuck in a loop when sharing a company on Remote Data Access
Description

The problem can manifest itself in several ways: 

  • Loops back and forth between "Please wait while we set up your company for collaboration" and "Downloading from Remote Data Access”
  • Loops back and forth between "Sage 50 is currently processing a data bundle for upload to Remote Data Access" and "Downloading from Remote Data Access" when trying to resume sharing of a paused company
  • Loops back and forth between "Processing Remote Data Access Data Bundle” and "Downloading from Remote Data Access"
  • Error: "The company backup failed to upload to Remote Data Access"
  • "Downloading from Remote Data Access" flashes during data upload
  • “Please wait while we setup your company for collaboration”
Cause

Damaged / incorrect files in the company folder.

Resolution
Section 1 - Delete SyncState.txt

Note: Do not delete SyncState.txt when the company is already successfully in a shared state, as this could lead to data loss. It is perfectly safe to delete if the company is not currently shared.

  1. If currently stuck in this loop, open the Task Manager and end task on Sage 50 Accounting to close it out.
  2. Browse to your company folder in the File Explorer. Refer to How to locate company directories. Close Sage 50.
  3. Delete the file SyncState.txt. This is a hidden file, so you may need to show hidden files and folders. See How to show file extensions and hidden files, folders, and drives.
  4. Attempt to share (or resume) the company again.
    Note: You may receive "An error occurred synchronizing with Remote Data Access. This company is not synchronized and will close in one minute." If this occurs, close the program, reopen it, and try sharing again.
  5. If the problem is not resolved, proceed to Section 2.

Note: See Error: "An error occurred synchronizing with Remote Data Access. This company is not synchronized and will close in one minute." if the sharing gets stuck on Processing Collaboration after receiving that error message.


Section 2 - Clean out company folder

  1. Create a clean data folder and expendable file cleanup. Refer to Create a clean data folder and expendable file cleanup.
  2. Open the company and go to Maintain, Users, Set Up User Security. Click Save and Close.
  3. Share the company again.



[BCB:161:Chat 50 US:ECB] 




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