Error: "Unable to Initialize the PDF Converter" when printing to PDF
Description

Confirm that Adobe Reader can be accessed independently instead of through Sage 100.

One incident was found where the Adobe Reader was waiting for License Agreement acception before opening.

Cause

The Sage 100 PDF Converter printer object is missing from Devices and Printers

Resolution

Install Adobe Acrobat

  1. Adobe Acrobat Reader installation can be found in Workstation Installation for Sage 100
  2. Adobe Acrobat Reader newer versions and be found at http:\\www.adobe.com

Install the Sage 100 PDF Converter if missing:

  1. From the Sage 100 Desktop, open File, select Run
  2. For Program, enter PL_AdvancedOptions_Ui
  3. Click OK
  4. Click on "Install Converter"
  5. From the Windows Desktop, access Control Panel, Devices and Printers
  6. Verify the Sage 100 PDF Converter now exists
    • Note: Previous versions of Sage 100 used the Sage PDF Converter

Additional steps for Windows 7, 8, 10 and Windows Server 2008, 2012:

  1. From the Windows Desktop, access Control Panel, Devices and Printers
  2. Right click Sage 100 PDF Converter (formerly Sage PDF Converter)
  3. Select Printer Properties from the pop-up menu
  4. Access the Ports tab
  5. Create a new Local Port with the name Sage (or Sage1) and set as default
  6. Access the Security tab
  7. Make sure Everyone has rights to Print, Manage this printer, and Manage documents
  8. Click OK in the Sage 100 PDF Converter Properties window to save changes and exit

If the issue persists:

  1. Check the Installation Log in PL_AdvancedOptions_UI. If error 1801 is present, reference KB 19429 for possible resolution.
  2. Restart the "Print Spooler" service in Windows Services
  3. Register C:\Windows\SysWow64\CDINTF300.dll (Versions 2013.7 and prior)
  4. Register C:\Windows\SysWow64\CDINTF500.dll (Versions 2013.8 and later)
  5. Change the Default Printer on the affected Workstation to a Local Printer (Microsoft XPS Document Image Writer is a good choice) then reinstall the Converter
  6. Restore the MAS90\Launcher\Sota.ini on the Server from a backup
    • This can also be performed on the Workstation for Sage 100 Advanced installations
    • Workstation Setup can be run to recreate this file

For Sage 100 Advanced, note that the workstation's "..\MAS90\Launcher" directory (where Workstation Setup was installed) has a SOTA.INI file with a section in it referencing the Sage 100 PDF Converter under the [Paperless] Section. If this is removed or cleared, the issue will occur.

DocLink: "Error Code 1801: The Printer Name is invalid" appears in the Converter Installation log and the Sage 100 PDF Converter is not installed in Sage 100
DocLink: How to install and uninstall the Sage 100 PDF converter
DocLink: What are the 5 methods to install the Sage PDF Converter
DocLink: Error: "Unable to initialize PDF Converter" when printing to Paperless PDF through a Citrix or Terminal Server session

[BCB:155:Chat 100 US:ECB]
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