Why is my report missing from my Reports menu? (Security settings for report are corrupt)
Description
Cause
  • Security Administration is not reading the security settings on the report correctly.
  • The report was added through the Information Assistant (IA) module.
Resolution
[BCB:5:Third-party support:ECB]

Note: Confirm the issue is not the issue found in article 34976 DocLink: Why is my custom report in Reports Manager but not on my reports menu? before proceeding with the solution below:

  1. Login to Sage 300 Construction and Real Estate as the Application Administrator.
  2. From the application's Reports menu, select Reports Manager.
  3. Select the report and click Change.
  4. Note the path and file name displayed in the File name field and click Cancel.
  5. Click Delete and when prompted click Yes.
  6. If the reports are missing from Desktop, then completely Close Reports Manager and then reopen it before moving on to step 7. Otherwise, skip this step.
  7. Click New and add the report back to the menu.
  8. Grant all applicable roles access to the report in Sage Desktop Security Administration. Refer to article ID 18199 DocLink: How do I give users or new users access to setup, tasks, tools, reports, or inquiries?
  9. Confirm that the users are able to access the report. If the report is not displayed, rename the design file and repeat steps 1-8.

For other possible solutions, refer to:

DocLink: How do I give users access to setup, tasks, tools, reports, or inquiries?
DocLink: Why is my report or inquiry missing from my Reports or Inquiry menu?
DocLink: Reports/inquiries are missing on the report/inquiry menu and/or in Security Administration
DocLink: Why is my custom report in Reports Manager but not on my reports menu?
DocLink: INTERNAL: Tracking cases where Sage 300 CRE Security has to be rebuilt

[BCB:156:Chat 300 CRE US:ECB]

Steps to duplicate
Related Solutions