Error: "No email program or default profile could be found"
Description
Cause
  • Using webmail, but not set up in Sage
  • Sage and Outlook aren’t running at the same security level
  • Using Windows apps version of Microsoft 365
  • Using an outdated version of Microsoft 365
  • Outlook isn’t set as the default email client
  • Damaged PTR files
Resolution

[BCB:5:Third-party support:ECB]

 

Outlook is a 64-bit version

See Compatible email programs to verify that your email program is compatible with your version of Sage. It must be a 32-bit version of Outlook as the 64-bit version is incompatible.

Verify this in Outlook by going to file File, Office Account, About Outlook. If it’s a 64-bit version, uninstall Microsoft 365 and reinstall the 32-bit version. See How do I install the 32-bit version of Microsoft Office?.


Outlook needs to be updated

Make sure the latest Microsoft 365 updates have been installed. Refer to Install Office Updates.


Outlook was installed as a Microsoft Home Store app

Ensure that Outlook is installed as a Program, not an Application (App) from the Microsoft Home Store.

Verify this by viewing Programs and Features in the Control Panel. If Microsoft Outlook or Microsoft 365 isn’t listed, it may be installed incorrectly as an App.

Remove the version of Microsoft 365 installed from the Windows app store:

  1. Type the program name in the Start menu.
  2. Right-click it and choose Uninstall.
  3. Reinstall Microsoft 365 from your Office.com account, making sure to install the 32-bit version. See How do I install the 32-bit version of Microsoft Office?.

Run both Sage and the email program with the same elevation under UAC (User Account Control)

  1. Close both Sage 50 and the email program.
  2. Right-click the Sage 50 Accounting shortcut and then select Properties.
  3. Select the Compatibility tab and then select Change settings for all users.
  4. Select Run this program as Administrator and then click OK.
  5. Repeat steps 2-4 for your email program shortcut.
    Note: The Outlook shortcut may not have a Compatibility tab in Properties. In this case, click the Advanced button under the shortcut tab and select Run as Administrator. Click OK and then OK again.
  6. Open Sage 50 and the email program.
  7. Verify you’re now able to email without error.

Note: If both programs are already set to Run this program as Administrator, uncheck Run this program as Administrator and then click OK. Test again to verify you’re now able to email successfully.


Verify your email address is in the correct format

  1. Select Maintain Customers/Prospects.
  2. Select the desired customer.
  3. Ensure the email address is in the correct email address format.

Note: Having more than one address with a space or commas can cause the error when batch emailing. This occurs when using the option not to see each email before sending. It works best to have only one email address on the customer record.


Uninstall/reinstall Email Writer

  1. Close Sage 50 Accounting.
  2. Press the Windows+R keys.
  3. Type Control and then click OK.
  4. Select Devices and Printers.
  5. Right-click Sage 50 E-mail Writer v3 and then select Remove Device. Also remove any other Peachtree or Sage 50 E-mail Writers found.
  6. Select any available printer.
  7. Select Print server properties at the top of the Devices and Printers screen.
  8. Select the Drivers tab.
  9. Select Amyuni Document Converter 450.
  10. Click Remove.
  11. Select Remove driver and driver package.
  12. Click OK.
  13. Go back to Print Server Properties.
  14. Select the Drivers tab.
  15. Select Amyuni Document Converter 300 or 500 (if present).
  16. Select Remove driver and driver package.
  17. Click OK. Repeat steps 8-17 above to remove any Amyuni Document Converter drivers found.
  18. Run repair; see How to run Repair.
  19. Press the Windows+R keys.
  20. Type Control, and then click OK
  21. Select Devices and Printers.
  22. Right-click Sage 50 E-mail Writer v3 and then select Printer properties.
  23. Select the Ports tab and then click the Add Port button.
  24. Select Local Port and then click the New Port button.
  25. Enter PDF1 as the port name and then click OK.
  26. Select the Advanced tab.
  27. Select Enable advanced printing features.
  28. Select Print directly to the printer.
  29. Click Apply and then click Close.
  30. Reboot the computer.
  31. Test the email function to verify it’s working correctly.

Damaged Windows profile

  1. Consult your local IT group or Microsoft support to create a new Windows profile.
  2. Set up the email account under the new user profile.

Only happens in one company

  1. Find the data path using How to find the data path and program path.
  2. Open the Forms folder in the data path.
  3. Sort the files by Type and delete all PTR files.
  4. See How to locate company directories and browse to the company folder.
  5. Sort the files by Type and delete all PTR files.
  6. Verify that you can email with no error.

Outlook.exe process hung

  1. Open the Task Manager and click the Details tab.
  2. Find the Outlook.exe process. Select it and click End Task.
  3. Open Outlook and attempt to email from Sage 50 again.

Emailing customer statements or invoices in a batch

Make sure that Outlook is already open before emailing.

Note: When sending emails in a batch with Outlook closed, it must open an instance of Outlook to send the email. If Outlook.exe then remains open, Sage may not be able to send the next email. Having the Outlook program open first alleviates this issue.


 

SolarWinds Take Control Agent running

If SolarWinds Take Control Agent (remote software often used by IT staff to work on your computer remotely) is running, it may cause this error even when using webmail.

  1. To see if this is the culprit, press Ctrl+Shift+Esc to start the Task Manager.
  2. Select the Details tab and look for the following processes:
    • TakeControlRDLdr.exe (Solarwinds MSP Remote Control)
    • BASupSrvcCnfg.exe (SolarWinds Take Control Agent)
  3. End the task on either of these processes if found.
  4. Open Sage and try to email. If successful, disable the above two items from Startup.
    1. Select the Startup tab on the Task Manager. Select the processes you want to disable and select Disable.
    2. Reboot the computer for the changes to take effect.

 

[BCB:25:My Sage - issues:ECB]




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