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The SmartPosting service has stopped and I can't start it

Created on  | Last modified on 

Summary

The SmartPosting service for Sage 50 Accounting has stopped.

Description

Cause

  • Damaged transactions
  • Environmental factors (antivirus, firewall)
  • Damaged program files
  • Out of balance transaction
  • SmartPosting has stopped in services
  • An expired support plan subscription
  • Security access level
  • Copied entire Company folder from a backup, replacing program files with old copies

Resolution

 NOTE: SmartPosting doesn't function in Sage 50 Cloud (hosted product). Sage 50 Cloud only has the options for Real-time or Batch posting. 

Restart Actian Zen and the SmartPosting service

  1. Make sure Sage 50 is closed on all computers.
  2. Press Ctrl+Shift+Esc on your keyboard to open the Task Manager.
  3. Select the Details tab and look for zenengnsvc32.exe.
  4. Select that process and click End Task at the bottom to end the process.
  5. Browse to the Services tab at the top and select Open Services at the bottom.
  6. Find Actian Zen Workgroup Engine.
  7. Right-click Actian and select Start.
  8. Locate Sage 50 SmartPosting Service 20xx in the same list.
  9. Right-click Sage 50 SmartPosting Service 20xx and select Start or Restart.

Post each journal manually

  1. Browse to Tasks at the top of Sage 50, scroll down to System, and select Post.
  2. Uncheck All journals.
  3. Select Cash Disbursement Journal and click OK.
  4. Repeat steps 1-3 doing each journal in the list one by one until the Sales Journal posts.
  5. If you receive an error about a journal out of balance, proceed to the next section to run the Journal Balances test.
  6. If all journals post without error, try to start SmartPosting again.

Run Journal Balances and GL Balances test

  1. Browse to Help at the top of Sage 50, scroll down to Support Utilities, and select Integrity Check.
  2. Select Backup and save a backup somewhere you’ll remember.
  3. Under file tests, check GL Balances and Journal balances and then click OK in the top left.

Expired support plan subscription

Computer name is over 15 characters

  • The computer name can be no longer than 15 characters for the SmartPosting service to start
  • If it's longer than 15 characters, change your computer name

The security access level doesn’t allow you to save changes

  1. Log in to the company with Admin access.
  2. Click SmartPosting Stopped link, click Start SmartPosting, and then click Close.

Environmental issues

Elevate the login credentials for SmartPosting

  1. Close Sage 50—U.S. Edition on all computers.
  2. Go to the server, and log in with Domain Administrative credentials.
  3. Select Windows+R keys, type SERVICES.MSC, and then click OK.
  4. Select Actian PSQL Workgroup Engine service and right-click it. Select Properties.
  5. Select Log On tab.
  6. Select Log on as This account.
  7. Enter the domain\administrator account and password, and then click OK.
  8. Select the Actian service again. Right-click it and select Restart.
  9. Select Sage 50 SmartPosting service, right-click, and then select Properties.
  10. Select Log On tab.
  11. Select Log on as This account.
  12. Enter the domain\administrator account and password, and then click OK.
  13. Right-click Sage 50 SmartPosting and select Restart.

Damaged program files

If none of the previous sections solved the issue, you’ll need to reinstall Sage 50.

  1. Uninstall Sage 50, referring to How do I uninstall without harming my data?
  2. Reinstall, referring to Installation instructions-Sage 50—U.S. Edition.

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Related Solutions

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Integrity Check Guide
Smart Posting has stopped due to damaged transactions