The program freezes or locks up when emailing or printing a form

Summary

Sage 50 Accounting freezes or locks up when emailing or printing a form.

Cause

  • Windows 11 updates
  • User Account Control (UAC) preventing communication with an email client or printer
  • Damaged PTR files
  • Damaged FRM files
  • AOL is set as the default email program
  • Actian service isn't running
  • Another software that prints/scans is interfering with the communication to the email client or printer

Resolution

 

CAUTION: Use caution when working with the below product functionality. Always create a backup of your data before proceeding with advanced solutions. If necessary, seek the assistance of a qualified Sage business partner, network administrator, or Sage customer support analyst.

 

 NOTE: If you are on Windows 11 using Microsoft Outlook, this is suspected to be caused by cumulative Windows updates for .NET Framework released on or after July 9, 2024. We recommend installing the August 13, 2024-KB5042099 Cumulative Update for .NET Framework.

If the problem still occurs, consult your local IT group or computer technician to remove updates KB5039895 and KB5041169. Outlook may be damaged in some cases, so if the problem still occurs, reinstall Outlook. A permanent solution is being investigated.

Run both programs with administrator rights

  1. Right-click the Sage 50—U.S. Edition shortcut and choose the properties.
  2. Select the Compatibility tab.
  3. Check Run the program as an administrator.
  4. Click OK.
  5. Repeat steps 1-4 for the Microsoft Outlook shortcut.

If the problem still occurs, try emailing from Sage 50 with Outlook completely closed:

  1. In Outlook, go to File > Exit to complete close Outlook.
    • If it's in the system tray, right-click the Outlook icon and select Exit
  2. Send emails from Sage 50.
  3. Reopen Outlook when done.

User Account Control blocking communication

See How to disable User Account Control (UAC).

Not using a desktop email client

  • Sage 50 Accounting's email function won’t work reliably if AOL or a similar web-based email program is set as the default client.
  • To resolve this, use a desktop email client such as Microsoft Outlook or Mozilla Thunderbird. For assistance setting up an email client, contact your local IT group or the email provider
  • Alternatively, install a PDF printer, such as CutePDF or PDF 995, and print the form to the PDF printer. This creates a PDF file that can then be manually attached and emailed to the email. 

Damaged PTR files

  1. Go to Maintain > Company information.
  2. Highlight the Directory. Right-click and choose Copy.
  3. Close Sage 50.
  4. Press Windows key + R to open a Run line.
  5. Paste the Directory and click OK.
  6. Delete all files that have a file type of PTR.
  7. Go up one folder to the data path and open the folder called Forms.
  8. Delete all of the files that have a file type of PTR.
  9. Open Sage 50 and try emailing or printing the form again.

Restore custom forms from a backup

  1. Try emailing the form using a standard form (Custom forms are indicated by a wrench icon next to the form name on the forms list):
    • If the error still occurs, skip to Option 5
    • If successful, continue to Step 2
  2. Select Reports & Forms, Forms, and select the type of form relevant to what you're trying to email (Invoices & Packing Slips, Customer Statements, etc.).
  3. Right-click and Delete all custom forms.
  4. Close Select a Report or Form.
  5. Select File, and then Restore.
  6. Select Browse.
  7. Select a backup file made before the error occurring (the date doesn't matter, as no data will be restored).
  8. Select Open.
  9. Select Next.
  10. Select Existing company.
  11. Select Next.
  12. Uncheck Company Data.
  13. Check Customized Forms.
  14. Select Next.
  15. Confirm the restore options, and then select Finish.
  16. If prompted about overwriting forms, choose Yes.
  17. When the restoration completes, your form will email successfully.

Replace all forms

  1. Close Sage 50.
  2. Open Computer.
  3. Browse to the Sage 50 data path; see How to find the data path and program path.
  4. Right-click and delete the Forms folder.
  5. Run Repair on Sage 50; see How to run Repair.
    Note: Repair must be run at the computer that hosts the Sage 50 data.
  6. Open Sage 50.
  7. If using custom forms, follow Option 4, Steps 5-18 to restore them.
  8. Verify that your form now emails successfully.

Save form with new name

See Cannot print form until it’s previewed.

Actian service isn’t running

Confirm that the Actian Zen service is running. See How to stop or start the Actian Zen database engine.

Program running in compatibility mode for an earlier version of Windows

  1. Right-click the Sage 50—U.S. Edition shortcut and choose the properties.
  2. Select the Compatibility tab.
  3. Remove the check mark in the box Run this program in compatibility mode for:.
  4. Click OK.

Damaged Windows profile

Create a new user profile in Windows.

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Solution Properties

Solution ID
221924850013163
Last Modified Date
Mon Nov 21 17:55:39 UTC 2022
Attributes
Product Details
Integrated Product: Blueprints
Views
0