Unable to save maintenance records
Description
Cause
  • Sage 50 Accounting running in Compatibility Mode
  • Damaged files from a failed data conversion
  • Incorrect program path
Resolution

Most common solutions

  • Reboot the computer where the error message occurs
  • For Sage 50 on a network, make sure the server and workstations all have the same version
  • If you recently converted your company to a new version, restore the backup made before conversion

Sage running in Compatibility Mode

  1. Close Sage.
  2. Right-click Sage icon and select Properties.
  3. Click Compatibility tab.
  4. Select Change settings for all users box.
  5. Clear Run this program in compatibility mode for box, if checked.
    • If that box is already clear, skip to Section 3
  6. Click Apply, then click OK and then Click OK again.
  7. Open your company in Sage 50 and verify if that fixed the issue.
  8. If it's still unresolved, then continue to the next section.

Disable Tablet PC Input Services

  1. Close Sage.
  2. Press Windows + R keys on your keyboard.
  3. Type services.msc, and then click OK.
  4. Double-click Tablet PC Input Service or Touch Keyboard and Handwriting Panel Service.
    • If you don't see either of these options, close the Services menu and skip to Section 4
  5. Stop the service.
  6. Double-click Tablet PC Input Service or Touch Keyboard and Handwriting Panel Service and then go to Properties.
  7. Change Startup type to Disabled.
  8. Select Recovery tab; change all options to Take no action, and then click OK.
  9. Close Services menu.
  10. Open Sage and verify that you can save.

Damaged files

  1. Select Maintain, and then select Company Information.
  2. Copy the company's Directory at the bottom.
  3. Close Sage.
  4. Press the Windows+R keys to load a run command.
  5. Paste the directory into the run command and click OK.
  6. Delete all files with the extension DDF (the data folder will have 12 of these) and COSESS.DAT.
  7. Open Sage and your company.
     NOTE: If you receive an error: "Sage 50 Accounting has stopped working" when you open the company, follow these steps. 
  8. Verify you’re now able to save the record.
    • If you still can't save, go to step 9
  9. Repeat steps 1 through 5 to open your company's directory, then go to step 10.
  10. Count the number of DDF files the system recreated.
    • If there are only 10 DDF files, go to step 11
    • If there are 12 DDF files, go to Section 5
  11. Remove and reinstall Actian Zen.
  12. Repeat steps 1 through 7, then verify you can save the record.
    • If you still can't save, go to Section 5

Damaged Reports folder

  1. Exit Sage from all computers.
  2. On the computer that hosts the data, browse to the data path.
  3. Rename Reports to OldReports.
  4. Run a repair.
  5. Repeat the steps in Section 4.
  6. Verify you can open your company without error and now are able to save the record.

Expendable file cleanup

  1. Select Maintain, and then select Company Information.
  2. Note the Directory for your company.
  3. Create a clean data folder and perform an expendable file cleanup.
  4. Verify that you can edit and create maintenance records.

Damaged data file

  1. Change to Accounting Period 1.
  2. Select File, and then select Data Verification.
  3. Select Both Tests (recommended), and then click Start.

 NOTE: If the test returns many errors, you’ll need to restore from a prior backup and run the test again. 

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