Error: "This program has quit. I/O Error. Pervasive status code 3012"
Description
Cause

The local Pervasive/Actian engine on a workstation or terminal server is:

  • Not running
  • Unable to start
  • Corrupt
  • Blocked by antivirus or firewall
  • Unable to connect due to network issues or settings
  • Install of Windows updates stopped the services

This can also occur if the .Net framework has become corrupted (due to Windows updates).

Resolution

 NOTE: This error doesn't affect your data. 

Correct issues with Pervasive/Actian

  1. Stop and start the local Pervasive/Actian engine
  2. If the Pervasive/Actian services won't restart on the workstation, reboot the affected workstation.
  3. If the error continues, or if the error occurs on all workstations, reboot the server. Have all users exit any Sage 300 CRE applications or other programs connected to the server before rebooting.
  4. If the service still won't start, uninstall Pervasive/Actian.
  5. Reinstall Pervasive/Actian.
  6. If the error continues to occur, verify virus scanning software excludes Pervasive/Actian directories on all machines. 
  7. Check Windows Firewall, set necessary exclusions for Pervasive/Actian in all networks. 
  8. Verify you can ping the server by hostname. If not, add the IP address and hostname for your server to the workstation's hosts file.
  9. Work with your IT professional to confirm that you have a Network Type of "Private".

Windows 10 machines with Windows Updates

  1. Check the Network and Sharing Center on the server and workstation. Verify the network type didn't change to "Public" after Windows Updates.
  2. Repair the latest version of .NET from Windows Programs and Features.

If you installed the Creator's Edition at any time on the machine, uninstall and reinstall it.

 

 

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