Error: "This program has quit. I/O Error. Pervasive status code 3012"
Description

Cause

The local Pervasive/Actian engine on a workstation or terminal server is:

  • Not running
  • Unable to start
  • Corrupt
  • Blocked by antivirus or firewall
  • Unable to connect due to network issues or settings
  • Install of Windows updates stopped the services

This can also occur if the .Net framework has become corrupted. (Usually due to Windows updates.)

Resolution
Note: This error does not affect your data.

  1. Stop and start the local Pervasive/Actian engine. See How do I restart the Pervasive/Actian Database Engine or Pervasive/Actian services on a server or workstation?
  2. If the Pervasive/Actian service(s) will not restart on the workstation, reboot the affected workstation.
  3. If error continues, or if error occurs on all workstations, reboot the server. Have all users exit any Sage 300 CRE applications or other programs connected to the server before rebooting.
  4. If the service still will not start, uninstall Pervasive/Actian. See How do I uninstall Pervasive/Actian?
  5. Reinstall Pervasive/Actian. See How do I manually install Actian PSQL version 12 Engine?
  6. If the error continues to occur, verify all virus scanning software excludes Pervasive/Actian directories on the server and workstations. See What Sage 300 Construction and Real Estate and Sage Estimating files and folders should I exclude from my antivirus software ...
  7. Check Windows Firewall, set necessary exclusions for Pervasive/Actian in all networks. See What firewall port exceptions to set for Sage 300 CRE accounting?
  8. Verify you can ping the server by hostname. If not, add the IP address and hostname for your server to the workstation's hosts file. See Add/Edit entries to the Hosts File

Windows 10 machines that installed Windows Updates:

  • Check Network and Sharing Center on server and workstation. Verify the network type isn’t set to "Public" after Windows Updates.
  • Repair the latest version of .NET from Windows Programs and Features

Note: If the update was the Creator's Edition or if it had ever been installed on the machine, it will need to be uninstalled and reinstalled.

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