Summary
Description
To Verify the Crystal Runtime version:
- Open the Registry
- Go to:
HKEY_Local_Machine\Software\Wow6432Node\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Crystal Reports - Check the value of CRRuntimeMSMVersion
Errors caused by Crystal Runtime version conflict errors include:
- Unable to cast COM object of Type...
- Load report failed
- The document has not been opened
Cause
A Crystal conflict occurs when different versions of SAP® Crystal Reports Runtime elements install on the same workstation. Programs like Sage Fixed Assets can include these runtime elements, or users can install them separately and manage them in Programs and Features.
Installing SAP® Crystal Reports runtimes SP20 (13.0.20) or earlier over Sage Fixed Assets 2018.1 or later causes report errors. Other applications that install these runtimes can also trigger these errors.
Resolution
In Windows Explorer:
For Sage Fixed Assets Lite Depreciation, Sage Fixed Assets Lite Depreciation for Sage 50, and Sage 50 Fixed Assets:
- Browse to C:\Program Files (x86)\Common Files\Sage SBD\SBDDesktop\v14.
- Copy/Paste SBDDesktop.exe.config to create a backup copy.
- Edit the SBDDesktop.exe.config.
- Delete all content between the first <> and the last <>.
- Save and close the file.
For Sage Fixed Assets Single User, Network and Premier:
Modify each listed .config file using these steps.
For each file:
- Browse to the file location.
- Create a backup copy and rename it with old at the end.
- Open the file for editing.
- Delete all content between the first <> and the last <>.
- Save and close the file.
Files and locations:
-
SBDDesktop.exe.config
C:\Program Files (x86)\Common Files\Sage SBD\SBDDesktop\v14 -
T2S8RptContainer.exe.config
C:\Program Files (x86)\Sage Fixed Assets\Common Files -
cdnTax.exe.config
C:\Program Files (x86)\Sage Fixed Assets\Depreciation (or Network/Premier Depreciation) -
fca.exe.config
C:\Program File (x86)\Sage Fixed Assets\FCA -
FasCIPNT.exe.config
C:\Program Files (x86)\Sage Fixed Assets\Planning (or Network/Premier Planning)
If the issue continues:
- Repair the Depreciation Client. Open the program and select Cancel when the version conflict error appears.