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Error: "Your database engine on computer [server] is unavailable. Please make sure that the computer is logged in or that the database service is running."

Created on  | Last modified on 

Summary

This article provides solutions to the error "Your database engine on computer server is unavailable. Please make sure that the computer is logged in or that the database service is running." that prevents opening the program.

Cause

  • Cannot ping the server by name and have it resolve to the correct IP address
  • Firewall blocking

Resolution

 CAUTION: This solution requires advanced knowledge of Windows security and network settings. Sage isn't responsible for any issues that arise from changes to these settings. Ensure you back up all system and application databases necessary for a complete restoration. It's advisable to contact a certified consultant or your system administrator for assistance.

Note: If you receive the error when opening one company but other companies or the sample companies open, refer to Error: “Your database engine on computer [computer name] is unavailable. Please make sure that the computer is logged in or that the database service is running." when opening one company.

Option 1: Verify the workstation and server can ping each other

  1. At the server, press Windows+R keys, enter cmd, and then select OK.
  2. Enter ipconfig /all and then press Enter.
  3. Note the host name and IPv4 address.
  4. Make sure the server name has no more than 15 characters.
  5. At the workstation, press the Windows+R keys, enter cmd, and then select OK.
  6. Enter ping [server's computer name].
  7. Verify a reply is successful and the IP address is same as Step 3.
  8. Complete the same steps from the workstation to the server.
  9. If the request times out or the IP address is not the same, you will need to contact your IT professional to correct this.

Option 2: Set Actian to run with a delayed start

  1. Close Sage 50 on all computers.
  2. Go to the server or the computer that holds the data.
  3. Press Windows+R keys to open a Run prompt.
  4. Type Services.msc and then select OK.
  5. Right-click Actian PSQL Workgroup Engine and then select Properties.
  6. Change Startup Type from Automatic to Automatic (Delayed Start), select Apply, and then click OK.
  7. Select the Recovery tab.
  8. Change First failure, Second failure and Subsequent failures to Restart the Service. Select Apply and then select OK.
  9. Verify the program opens on both the server and workstation.

Option 3: Configure security software to allow program files to pass through 

See Files to allow through firewall and antivirus.

Option 4: Verify data path

  1. At the server, browse to your company data location. See How to find data path and program path.
  2. If the data path is in Public or Users folder, you will need to uninstall Sage 50 and reinstall so that the data location is on a local drive.
  3. At the workstation, verify the data path is the mapped drive of the shared folder of the server.

Option 5: Verify permission are set correctly on the shared folder

Refer to Verify my data file permissions are correctly set.

Option 6: Uninstall and reinstall Actian

See How to completely remove and reinstall Pervasive/Actian.

Option 7: Run Actian as Administrator

  1. Press Windows+R keys to open a Run prompt.
  2. Type Services.msc and then select OK.
  3. Right-click Actian PSQL Workgroup Engine and then select Stop.
  4. Right-click Actian PSQL Workgroup Engine and then select Properties.
  5. Select the Log On tab.
  6. Check the field that says Allow service to interact with desktop, and then select OK.
  7. Select This account.
  8. Enter your Windows Administrator user name.
  9. Enter the password in Password and Confirm password, and then click OK.
    Note: If the Administrator does not have a password set, one must be set up.
  10. Right-click Actian PSQL Workgroup Engine, and then select Start.
  11. Close Services.
  12. Verify that Sage 50 opens on the server, and then the workstations.

Option 8: Install Windows updates

Check for Windows updates and install any recommended updates. Consult your local IT group, computer technician, or Microsoft support if assistance is needed.

Option 9: Target line indicated on the icon is incorrect

  1. Browse to your program path. See How to find data path and program path.
  2. Right-click the Sage 50 shortcut and then select Properties.
  3. Verify the Target line matches the location of the Program Path noted in Step 1.
  4. If not, delete the icon.
  5. Browse to the Program Path noted in Step 1.
  6. Right-click Peachw.exe.
  7. Select Send to, Desktop (create shortcut).
  8. Verify Sage 50 opens without error.

Option 10: Uninstall and Reinstall Sage 50 to a new program path

  1. Uninstall Sage 50.
  2. Reinstall the program to a new program path. See How do I install to a different program path?.

Option 11: Computer names on network

Verify the workstations and server all have unique names. Refer to How can I find the name of my computer?.

Option 12: Configure Windows OS to prefer IPv4 addresses over IPv6

Follow How to set Windows 10 to prefer IPv4 over IPv6.

Option 13: Create new local data path

  1. Select Start, All Programs, and then select Sage 50 20[Version].
  2. Select Sage 50 Resources and Help, and then select Technical Support Utilities.
  3. Double-click Database Repair Utility.
  4. Scroll to bottom of web page.
  5. Download DBRU that coincides with your current version.
  6. Run DBRU.
  7. Click OK to the warning and Agree to the terms.
  8. Click Run next to Create New Local Datapath.
  9. Click OK to the message stating that Sage 50 must be closed on all computers.
  10. Click the second Browse button to move a company over to the new data path when it moves the data path.
  11. Once the DBRU finishes the move, open Sage 50 to verify that it now opens successfully.

Option 14: Mapped drive by IP address

Map the network drive by computer name. Follow How to map a network drive.

Option 15: Program not installed to Program Files (x86) directory

If on a 64-bit Windows machine, the program must be installed into the C:\Program Files (x86) directory. If not, uninstall and reinstall the program to the proper directory.


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