Skip to content
logo Knowledgebase

Performance issues on a standalone or network

Created on  | Last modified on 

Summary

Performance issues on either a network or standalone installation; program is slow, locks up, hangs, or freezes.

Cause

  • Actian is running as a pre-load or is damaged and needs to be reinstalled
  • Permission settings over the network are preventing Sage 50 from running with full control
  • Slow network speed
  • Data size is over the recommended size for optimal system performance

Resolution

CAUTION: Sage Customer Support does not assist with issues related to third-party products or enhancements, hardware, report customizations, state or federal tax-related questions, or specific accounting questions. Please get in touch with your Sage business partner, network administrator, or accountant for assistance. Please refer to our Scope of Support document for details.


Section 1: Uninstall and reinstall Actian Zen

Section 1a: Switch ini file to look at shared network drive instead of UNC path

Section 2: Sharing permissions & security

  1. If the shared data folder's permissions and/or security have not been set properly, it can cause slowness; refer to Verify my data file permissions are correctly set.
  2. Make sure that the network drive at each workstation is mapped directly to the shared folder and not a sub-folder (for example, Sage 50 is shared, but the drive is mapped to Company); if it is, disconnect and remap the drive.

Section 3: Sage company size

  • The size of a Sage company directly affects program performance; large databases can result in longer load times for the program.
  • To check a company's size, select Help, Support Utilities, and then File Statistics.
  • Large companies should be purged to remove old transactions/inactive records and decrease the company size; refer to When should I purge my data?.

Section 4: User Account Control (UAC)

Section 5: IPv6

  • If using Windows 8.1, or 10, disabling IPv6 will significantly improve Sage's performance but can causes issues with Windows OS.
  • Instead configure Windows OS to prefer IPv4 addresses over IPv6, refer to How to set Windows 10 to prefer IPv4 over IPv6
  • Consult with your Local IT or Network Administrator for assistance with this.

Section 6: Anti-virus and firewall software

Section 7: Network connection

  • Sage is not supported on wireless networks. Use on a wireless network can result in performance and/or data integrity issues. It is strongly recommended to use a hard-wired connection with the program.
  • Verify the server and workstation(s) are on the same domain or workgroup.
  • Verify the server can ping the workstation by name and receive a response from the correct IP address and that the workstation can ping the server by name; refer to How do I ping the server from a workstation or vice versa?
  • Check the network speed; follow How to check network speed
  • Network-related issues can be confirmed by changing one of the workstations to a local data path and opening a sample company. If the performance issues desist after bringing the data to the local machine, contact an IT professional to troubleshoot across the network; refer to How to change a workstation into a standalone temporarily after a server failure
  • Verify there are no bad or faulty network cables or network cards in the environment. Replace any damaged equipment.
  • If the computer experiencing performance issues has dual network interfaces (active wireless and wired network connections), disable the unused interface.
  • Consult with your IT professional to diagnose and repair network latency.

Section 8: Memory & processor speed

  1. Make sure each computer meets at least the minimum processor and RAM requirements for Sage; refer to System Requirements: Sage 50—U.S. Edition 2023.
  2. At the server, you should increase your amount of RAM in correspondence with the number of workstations accessing Sage; a good rule of thumb is to have 2GB of RAM per workstation.
  3. More memory/processor speed will also be required if working in multiple companies at once.
  4. Check Sage's performance at the server; if the server is slow, every workstation will also be slow.
  5. Verify the processor and memory resources have not been artificially limited by pressing Windows+R keys, type msconfig, and then click OK.
    Note: If prompted to allow the program to make changes, select Yes.
  6. Select Boot tab.
  7. Select Advanced options.
  8. If either Number of processors or Maximum memory are selected, clear them.
  9. Select OK.
  10. Select OK again.
  11. Restart computer.

Section 9: Hard Drive space and virtual memory

  • Each PC's hard drive should have a minimum of 1 GB or three times the company database size, whichever is larger, of free space.
  • Running Windows' Disk Cleanup and Defragmenter utilities at each PC will optimize free disk space.
  • Each computer's virtual memory should be set so it at least matches the amount of RAM on the machine.
  • As with RAM, the more virtual memory a computer has, the better it will run.
  • Follow the link in Additional information, below, for Microsoft instructions on checking and changing the amount of virtual memory.

Section 10: Background applications

  1. Other programs and background applications running at the same time as Sage may cause slow performance.
  2. Try rebooting your computers into Selective Startup to verify if background programs are affecting Sage's performance; follow How to boot into selective startup
  3. If performance improves after doing so, start re-enabling services and startup items one at a time until the one causing the issue is found.

Section 11: Data entry

The following changes can improve performance but are not always necessary. It is best to make a few changes and then work in Sage to test the results.

  • Change Global Options
  1. Select Options, and then Global.
  2. Select General tab.
  3. Check one or more options under Improve Performance.
  4. Clear Smart Data Entry.
  5. Select OK.

Note: When entering transactions, use unique reference (invoice, check, etc.) numbers.

  • Change Action Items settings
  1. Select Tasks, Action Items.
  2. Select Options, and then Transactions tab.
  3. Clear each Create Event option.
  4. Select Start Up tab.
  5. Clear Display Action Items each time a new company is opened.
  6. Select OK, and then Close.

Section 12: Compatibility settings

  1. Right-click Sage Icon, and then select Properties.
  2. Select Compatibility tab.
  3. If Run this program in compatibility mode for is selected, clear it.
    Note: If the check box is grayed out, just continue to the next step.
  4. Select Change settings for all users.
  5. If Run this program in compatibility mode for is selected, clear it.
  6. Select Run this program as an administrator.
  7. Select Apply.
  8. Select OK.

Section 13: Microsoft .NET issues

Section 14: User does not have the correct access

Each user in the network needs either Administrator or Power User access.

Section 15: Oversized form (.FRM) file(s)

  1. Check the Forms and individual company directories, sorting the files in the directory by size.
  2. Any large forms can be moved out of the Forms and individual company directories.
  3. If these are custom form files, they can be re-customized.
  4. Verify the program is more responsive.

Section 16: Uninstall and reinstall Sage

  1. Follow How do I uninstall the program?
  2. Reinstall Sage; refer to Installation Instructions - Sage 50—U.S. Edition

Section 17: Windows Update:

  1. Check for any pending or needed windows updates, Contact an IT professional or Microsoft support for assistance.
  2. You can view your Windows updates in Windows 10, by typing updates where it says Type here to search on your bottom taskbar.
  3. On the menu that appears you can then click Check for updates.


Chat with support