Skip to content
logo Knowledgebase

Sage 300 CRE and Sage Estimating antivirus exclusions

Created on  | Last modified on 

Summary

Required antivirus and firewall exclusions Sage 300 CRE. In addition to Sage 300 CRE, it can affect integrated applications such as Estimating, Actian/Pervasive, Crystal Reports, Aatrix and other third-party programs.

Cause

Active scanning by antivirus programs may cause:

  • Poor performance
  • Sage 300 CRE and Sage Estimating applications to shut down unexpectedly
  • File locking in Pervasive/Actian
  • Sage System Verifier to stall

Resolution

 

CAUTION: Sage Customer Support cannot assist with issues related to third-party products or enhancements, hardware, report customizations, state or federal tax-related questions, or specific accounting questions. Refer to our Scope of Support document for details. For assistance, contact your Sage business partner, network administrator, or accountant. 

 

 NOTE: 

  • We recommend scanning these files at a time when they are not in use (for example, schedule a daily scan at 3:00 a.m.).
  • Configure your antivirus software to quarantine rather than delete suspected files. Some antiviruses use predictive methods, which can result in false positive detection of viruses in legitimate files. 

Antivirus folder and file exclusions for the supported versions

Workstations and Terminal Servers

  • C:\Program Files\Actian
  • C:\Program Files\Sage
  • C:\Program Files (x86)\Aatrix Software
  • C:\Program Files (x86)\Actian
  • C:\Program Files (x86)\Business Objects
  • C:\Program Files (x86)\SAP BusinessObjects
  • C:\Program Files (x86)\Common Files\Sage
  • C:\Program Files (x86)\Event 1
  • C:\Program Files (x86)\Sage
  • C:\Program Files (x86)\Timberline Office
  • C:\ProgramData\Aatrix Software
  • C:\ProgramData\Actian
  • C:\ProgramData\Sage
  • If using the Property Management application and Windows Security Real-Time Protection is enabled, add pm.exe as a Process exclusion. See Error: "Aborted. I/O error" or "Failed" (during PM Trial Run tasks)
  • Any mapped drives or network locations mapping back to Sage 300 CRE (Timberline) data and program files

Sage Server

  • C:\Program Files\Actian
  • C:\Program Files\Sage
  • C:\Program Files (x86)\Aatrix Software
  • C:\Program Files (x86)\Actian
  • C:\Program Files (x86)\Business Objects
  • C:\Program Files (x86)\SAP BusinessObjects
  • C:\Program Files (x86)\Common Files\Sage
  • C:\Program Files (x86)\Event 1
  • C:\Program Files (x86)\Sage
  • C:\Program Files (x86)\Timberline Office
  • C:\ProgramData\Aatrix Software
  • C:\ProgramData\Actian
  • C:\ProgramData\Sage
  • Sage 300 CRE (Timberline) data files
  • Any mapped drives mapping back to Sage 300 CRE (Timberline) data and program files

 NOTE: Aggressive antivirus softwares attack Sage as soon as it downloads damaging the installation files. We recommend to exclude the folder where you download and extract the Sage.zip file. 

Firewall exclusions

Sage 300 CRE and some Sage Estimating versions use the Pervasive/Actian/Zen database engine. The Pervasive/Actian/Zen requires access to specific ports on your network and firewall software. The authentication process through named pipes needs access to these ports.

Required ports

  • Port 3351 (TCP)
  • Port 1583 (TCP)
  • Ports 137-139 (UDP)
  • Ports 8101-8102 (TCP)

Additional ports that may be needed

  • Port 80 (TCP)
  • Port 445 (TCP)
  • Port 139 (TCP)
  • Port 515 (UDP)
  • Port 161 (UDP)
▼ Antivirus folder and file exclusions for Sage 300 CRE legacy versions

 NOTE: For safe and secure operation, we highly recommend that you use the supported Microsoft operating system.

Workstations and Terminal Servers

  • Sage 300 CRE and Sage Estimating program files (include all):
    • 9.7.x and later
      • C:\Program Files (x86)\Sage
      • C:\Program Files\Sage
    • 9.5.x and later
      • XP/2003: C:\Documents and Settings\All Users\Application Data\Sage
      • Vista/Win7/2008: C:\ProgramData\Sage
      • C:\Program Files (x86)\Timberline Office
      • C:\Program Files (x86)\Common Files\Sage
      • C:\Program Files\Timberline Office
      • C:\Program Files\Common Files\Sage
  • Any mapped drives or network locations mapping back to Sage 300 CRE (Timberline) data and program files
  • Pervasive/Actian:
    • 16.1 and Later:
      • C:\Program Files (x86)\Pervasive Software or C:\Program Files (x86)\Actian.
      • C:\Program Files\Pervasive Software or C:\Program Files\Actian.
    • 9.7.x - 15.1:
      • C:\Program Files (x86)\Pervasive Software or C:\Program Files (x86)\Pervasive
      • C:\Program Files\Pervasive Software or C:\Program Files\Pervasive
    • Vista/Win7/2008
      • C:\ProgramData\Pervasive Software or C:\ProgramData\Pervasive Software\Actian.
    • 9.6.x and earlier
      • C:\Pvsw
  • Crystal Reports
    • 9.5.x and later, using Crystal XI
      • C:\Program Files (x86)\Business Objects
      • C:\Program Files\Business Objects
    • 9.4.x and earlier, using Crystal 10
      • C:\Program Files\Common Files\Crystal Decisions
  • Aatrix
  • Event 1
    • 9.7.x and later
      • C:\Program Files (x86)\Event 1
      • C:\Program Files\Event 1
    • 9.4.x and earlier
      • C:\Windows\system32\srvany.exe
      • C:\Winnt\system32\srvany.exe (for a terminal server that is not the file server)
  • Property Management application

Sage Server

  • Sage 300 CRE and Sage Estimating program files (include all):
    • 9.7.x and later
      • C:\Program Files (x86)\Sage
      • C:\Program Files\Sage
    • 9.5.x and later
      • XP/2003: C:\Documents and Settings\All Users\Application Data\Sage
      • Vista/Win7/2008: C:\ProgramData\Sage
      • C:\Program Files (x86)\Timberline Office
      • C:\Program Files (x86)\Common Files\Sage
      • C:\Program Files\Timberline Office
      • C:\Program Files\Common Files\Sage
  • Sage 300 CRE (Timberline) data files
  • Any mapped drives mapping back to Sage 300 CRE (Timberline) data and program files
  • Pervasive:
    • 9.7.x and later
      • C:\Program Files (x86)\Pervasive Software or C:\Program Files (x86)\Actian.
      • C:\Program Files\Pervasive Software or C:\Program Files\Actian.
    • XP/2003
      • C:\Documents and Settings\All Users\Application Data\Pervasive Software.
    • Vista/Win7/2008
      • C:\ProgramData\Pervasive Software or C:\ProgramData\Actian.
    • 9.6.x and earlier
      • C:\Pvsw
  • Crystal
    • 9.5.x and later, using Crystal XI
      • C:\Program Files (x86)\Business Objects or
      • C:\Program Files\Business Objects
    • 9.4.x and earlier, using Crystal 10
      • C:\Program Files\Common Files\Crystal Decisions
  • Aatrix
  • Event 1
    • 9.7.x and later
      • C:\Program Files (x86)\Event 1 or
      • C:\Program Files\Event 1

 

 NOTE: If configuring these exclusions doesn't improve the performance, we recommend temporarily removing the antivirus for performance testing. If the performance improves, reinstall the antivirus and contact your antivirus provider for further assistance.  

 

Need more help?

Chat now

 

 

Related Solutions

What firewall port exceptions to set for Sage 300 CRE? 

How do I use the PING command to troubleshoot network connectivity or slowness? 

Why is Sage Estimating or Sage 300 CRE so slow? 

What Sage Paperless Construction files and folders should I exclude from my antivirus software scan?

Sage Estimating firewall ports (SQ)

Anti-virus and SQL Server (SQL)