Skip to content
logo Knowledgebase

Sage 300 Construction and Real Estate and Sage Estimating (DOS Pervasive SQL) Upgrade Paths

Created on  | Last modified on 

Summary

Upgrade version steps for Sage 300 Construction and Real Estate and Sage Estimating (Pervasive)

Resolution

CAUTION: If you use third-party products that integrate with your Sage product, check with the vendor of your third-party product to ensure their product is fully compatible with this release. If you integrate with other Sage products, check with your business partner or Sage to ensure that these components are compatible. 

Depending on the Sage product and version you have installed, you may be required to follow a particular upgrade path to get to the latest version of the software. See the tables below for more information.

 

Please select the product you need to upgrade:

 

Sage 300 Construction and Real Estate (formerly Timberline Office) Upgrade Paths

Notes:

  • IMPORTANT: Run File Doctor on all files in your current version before upgrading to the next version. Even if you are not receiving a corrupt file message, there may be some issues File Doctor finds that it will not be able to fix after upgrading. See How do I use File Doctor to fix my corrupt data files?
  • For assistance with an upgrade or migration, you can also contact your Business Partner, Sage Consultant or Sage Expert Services
Upgrade From

Upgrade Path

20.x

If you are on version 20.1, 20.2, 20.3, 20.4, or 20.5, you can upgrade directly to version 23.1

NOTE: Australia only: you can upgrade from 18.1.3 Rev 3 directly to version 22

18.x

If you are on version 18.1, 18.2, 18.3 or 18.4, upgrade to 20.5 and then 23.1

17.1 or earlier

Contact your Business Partner, Sage Consultant or Sage Expert Services available for Sage 300 Construction and Real Estate to plan and implement the upgrade path.

Note 1:

  • You can upgrade the data files for accounting applications, except for Purchasing and Inventory and Service Management, using TS-Main, Tools, Upgrade files or Sage Timberline Office, Desktop, Tasks, Common Tasks, Tools, Upgrade Files or Desktop, Applications, Common Tasks, Tools, Upgrade Files.
  • You must open and upgrade Service Management data files at the server the first time you open the application following the upgrade.
  • You must open and upgrade Purchasing and Inventory data files at the server the first time you open the application, while logged into the console of the server, and not through a Remote Desktop session.
  • Upgrading data on a workstation will incorrectly set DSNs and cause data access errors after the upgrade is performed.
  • For information on how to upgrade data files, see How do I upgrade my data files in Sage 300 CRE?

Note 2: If your products are on version 13.1 or earlier, upgrade both products to 15.1 and upgrade your data before upgrading both products to version 17.1.

Note 3: If you use Purchasing and/or Inventory and are on version 8.3.x or 9.1.x of Timberline, you must apply Software Alert 05-M or 05-P prior to upgrading to 9.4.1. If you do not have these updates, contact Sage Customer Support for assistance. Also, if using Purchasing and/or Inventory, we do not recommend using version 12.1. Upgrade to 13.1 or higher.

Document Management

Important Note: Document Management has been retired. DO NOT install Accounting 18.3 or higher if you integrate with Document Management. If you do, it will uninstall Document Management and DocuVault. See FAQ Document Management retirement (includes a suggested alternate product). Also see How do I migrate Document Management to a standalone environment for image retrieval? (includes instructions on running Document Management in a standalone environment using version 18.2.)

Sage Estimating Upgrade Paths

You can upgrade directly from any Pervasive/Actian Estimating products version for Windows to another Pervasive/Actian Estimating Products version for Windows. For example, you can upgrade directly from Estimating for Windows 3.1 to Sage Estimating 13.1. The upgrade paths for Sage 300 Construction and Real Estate do not apply to Sage Estimating. If your current Estimating version is for DOS, use the following table to determine which version you can upgrade to.

Current version you are on

Version you can upgrade to

DOS 1.0 to 5.0

DOS 6.0

DOS 6.0 to 10.0

Estimating for Windows 3.1

Estimating for Windows 3.1 **

Any Pervasive/Actian Estimating version (i.e. 15.1)

Any Pervasive/Actian Windows version (e.g. 9.8)

Any Pervasive/Actian Estimating version (i.e. 15.1)

Pervasive/Actian Estimating version 9.6 ***

Any SQL Estimating version up to 20.1

Any SQL Estimating version (i.e. 14.12)

Sage Estimating 22.1

For converting DOS version to Windows version, see How do I convert my Estimating DOS files to the current Windows version? (DOS Pervasive SQL)

** Note: Beginning with the 17.1 version of Sage Estimating you will not be able to upgrade data from v4.0 (pre-Pervasive) Estimating. You will need to upgrade these older data files with v16.1 or earlier.

*** Note: To upgrade from the Pervasive/Actian version of Sage Estimating to the Microsoft SQL version of Sage Estimating, you must be on at least version 9.6 of the Pervasive/Actian Sage Estimating version.


Chat with support



Related Solutions

´╗┐Install and / or Upgrade Sage Estimating (SQL)

Can I go directly to the newest Sage Estimating version? (upgrade path)

Sage 300 Construction and Real Estate: Download Portal

How do I convert my Estimating DOS files to the current Windows version? (DOS Pervasive SQL)

How do I migrate data from Pervasive to SQL Estimating (only for Sage Estimating 20.1 and Earlier) (SQL)