Payroll checks won't post
Description
Cause

Possible causes

  • The check has a direct deposit deduction and the direct deposit wasn’t generated
  • The check has a check date in a future period (you didn't close the Payroll month)
  • PR or CM files are locked on the server due to an abort or unexpectedly ended process
  • Intercompany accounting isn’t configured properly
  • Check status isn’t "Printed" or "Manual"
  • Tax was deleted from the system after the tax calculated on the check
  • The Employee is in use in an interfacing application. Example: Cash Management Bank register
  • You generated a direct deposit, but the Withdrawal didn’t post in Cash Management
  • There are time entries on the PR check that originated from Service Management but don't exist in the SM Time Entry records
Resolution

Review your posting report

  1. Review the Post Check report that prints when you post checks in payroll for any error messages.
  2. If a message prints "Errors found, see the system log in the log viewer for details" review the log. Go to your Tools menu and selecting Log Viewer.
  3. If there are no "Errors" found in the log viewer, have everyone else exit the software and try posting again.
  4. Review the links below for possible solutions based on the log results.

Possible solutions

Check status not Printed or Manual

Future check date

Files locked

Service Management entries

Other solutions

Steps to duplicate
Related Solutions