Why will my payroll checks not post?
Description
Cause
  • Check has a direct deposit deduction and the direct deposit was not generated
  • Check has a check date in a future period. (The month in Payroll has not been closed)
  • Due to an abort or unexpectedly ended process, PR or CM files may be in use locked at the Server.
  • Intercompany accounting is not configured properly
  • Check status is not "Printed" or "Manual"
  • Tax has been deleted from the system after the tax calculated on the check.
  • The Employee is in use in an interfacing application. Example: Cash Management Bank register.
  • Direct Deposit was generated, but the Withdrawal did not make it to Cash Management.
  • There are time entries on the PR check that originated from Service Management that do not exist in the SM Time Entry records.
Resolution

Review the Post Check report that prints when you post checks in payroll for any error messages.

If a message prints "Errors found, see the system log in the log viewer for details" review the log by going to your Tools menu and selecting Log Viewer.

If there are no "Errors" found in log viewer, have everyone else exit the software and try posting again.

Review the links below for possible solutions.

DocLink: How do I generate direct deposits?
DocLink: How do I print checks in Payroll?
DocLink: Error: Service Management returned the following error: Unable to process transaction. Unable to locate the specified time entry. Employee [Employee ID].
DocLink: Error: "File in Use" or "Record in use"
DocLink: Error: "No information to print." (generating direct deposits)
DocLink: How do I change the check date on a Payroll check?
DocLink: Error: "No Information to Print" (duplicate check in Cash Management)
DocLink: Error: "Future check found"
DocLink: Error: Tax [tax id] not found in system file
DocLink: My payroll check did not post (Check status not Printed)

My Payroll check will not post (Missing Salary Hours on Paygroup)


Steps to duplicate
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